Ohhhh Noooo!! Ok I need help fast

Discussion in 'HOWTO-Related Questions' started by Tezux, Jun 30, 2009.

  1. Tezux

    Tezux New Member

    Debian Lenny The Perfect Server

    Up to now has been running like a dream. Then a couple of days ago I was sent an email to my hotmail address which made me think, why are they sending mail to there and not my mail server anymore? Ok so I run up to the mail server and test it, it seemed ok, mail LOOKED like it was sending and being recieved without any problems. So then I try sending myself an email and sure enough, the mail isnt actually being recieved or sent, although its all in the mail log. It looks fine with no errors until you try finding the mail and theres nothing. Damn.
    I have very important emails in my logs that I need fast. How can I read these emails from shell or whatever is the fastest way possible so I can reply to these people.

    Only error I see is this in /var/log/mail.log

    ]un 29 14:42:12 mail maildrop: Home directory owned by wrong user.

    I tried re-configuring postfix but that didnt do anything.
    Can someone help, I need to get this lost mail I have been sent fast:(
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you install ISPConfig 3?
     
  3. Tezux

    Tezux New Member

    Yes I have everything installed as in this Tutorial

    http://howtoforge.org/perfect-server-debian-lenny-ispconfig3

    How can I access my mail thats been sent to the server but is not receivable using my email client program?
    I have check /var/vmail/user but all the folders seem to be empty, I dont understand? The mail must be on the server somewhere as the Logs say that the mail has been received, I can see it in the Logs:(:(
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post an excerpt of the log files and post the output of:

    ls -la /var/vmail

    and post the output of:

    postqueue -p
     
  5. Tezux

    Tezux New Member

    Here you go till

    [email protected]:~$ ls -la /var/vmail
    total 32
    drwxr-xr-x 4 gt gt 4096 2009-05-26 19:24 .
    drwxr-xr-x 17 root root 4096 2009-05-26 17:49 ..
    -rw-r--r-- 1 vmail vmail 220 2008-05-13 07:02 .bash_logout
    -rw-r--r-- 1 vmail vmail 3116 2008-05-13 07:02 .bashrc
    drwxr-xr-x 12 vmail vmail 4096 2009-06-23 17:46 example.com
    -rw------- 1 vmail vmail 1240 2009-05-26 17:49 .mailfilter
    drwxr-xr-x 3 root root 4096 2009-05-31 17:05 mailfilters
    -rw-r--r-- 1 vmail vmail 675 2008-05-13 07:02 .profile
    [email protected]:~$



    postqueue -p

    71DA522C4B8 7939 Sat Jun 27 08:33:48 [email protected]
    (temporary failure. Command output: /usr/bin/maildrop: Home directory owned by wrong user.)
    [email protected]

    It just says this message over and over again
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    chown vmail:vmail /var/vmail
     
  7. Tezux

    Tezux New Member

    Sorry Im not that good at Linux, what do I do after that?
    I know it changes the owner permissions but the files inside /var/vmail/example.com which are the directorys for all my email addresses of my domain are still not readable as I dont have the permissions to access them. I tried changing the permissions to get into them but theres nothing in there, they are empty, my mail isnt there?
     
  8. Tezux

    Tezux New Member

    Ah ok got it sorted, problem solved. I changed my postfix config and forgot to change it back again. Thats what happens when you have tried a million things and dont remember everything you tried I guess :(

    I also didnt realise the mail in /var/vmail was not viewable as a text file, so thats why it always appears blank, that might be useful to someone else thinking the same as I was.

    Thanks till

    So can anyone explain to me why this problem may have occurred with the mail server just suddenly? One day it was working fine and the next day it did this and I handt done any changes previous to the problem? Weird no?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Someone has changed the owner of the folder /var/vmail from vmail to gt. As gt is no common system user, it muste be an account from you or from one of your users.
     
  10. Tezux

    Tezux New Member

    Ah I know what happened now, someone at work tried to back up the vmail folder and were having problems with it, dont you love it when your told about this 2 days later. :mad:

    Thanks for helping me Till, I really appreciate it
     

Share This Page