Odd question - need to map ip address to website - non-threatening title :)

Discussion in 'ISPConfig 3 Priority Support' started by craig baker, Nov 11, 2020.

  1. craig baker

    craig baker Member HowtoForge Supporter

    odd question - due to some problems getting past a router I need to have the local LAN clients able to access nextcloud via the internal lan address. say its is the server IP. (it is actually). for the internal lan clients - brings up the apache test page. I thought specific ip address accesses would be mapped to 000default.local.vhost but it seems not.
    000default.local.vhost has the line which I added:
    DocumentRoot /var/www/nextcloud.site2.com/web/nextcloud/
    but this is not being acted upon. It bring up the Apache2 Test page, not the ISPConfig this is your website page.
    and as well its not mapping to /var/www/html. so what I need to do is have bring up the same vhost url as nextcloud.site2.com (which is a vhost).
    I added as an IP under the server IP but that had no effect.
    from : apachectl -t -D DUMP_VHOSTS:
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/httpd/conf/httpd.conf:356 (probably better remove that myself)
    VirtualHost configuration:
    *:8081 96-88-250-105-static.hfc.comcastbusiness.net (/etc/httpd/conf/sites-enabled/000-apps.vhost:9)
    *:8080 96-88-250-105-static.hfc.comcastbusiness.net (/etc/httpd/conf/sites-enabled/000-ispconfig.vhost:9)
    *:80 is a NameVirtualHost
    default server 000default.local (/etc/httpd/conf/sites-enabled/100-000default.local.vhost:7)
    port 80 namevhost 000default.local (/etc/httpd/conf/sites-enabled/100-000default.local.vhost:7)
    alias www.000default.local
    port 80 namevhost site1.com (/etc/httpd/conf/sites-enabled/100-siite1.com.vhost:7)
    alias www.site1.com
    port 80 namevhost nextcloud.site2.com (/etc/httpd/conf/sites-enabled/100-nextcloud.site2.com.vhost:129)
    alias www.nextcloud.site2.com
    ..others removed

    *:443 is a NameVirtualHost
    default server site1.com (/etc/httpd/conf/sites-enabled/100-site1.com.vhost:126)
    port 443 namevhost site1.com (/etc/httpd/conf/sites-enabled/100-site1.com.vhost:126)
    alias www.site1.com
    port 443 namevhost nextcloud.site2.com (/etc/httpd/conf/sites-enabled/100-nextcloud.site2.com.vhost:129)
    alias www.nextcloud.site2.com
    port 443 namevhost ns1.site2.com (/etc/httpd/conf/sites-enabled/100-ns1.site2.com.vhost:126)

    I note that 000default.local seems you cannot have SSL - when I checked the boxes and saved, they came back unchecked!
    so the https default server is site1 (also not displayed - just get Apache2 Test Page).
    default server for http SHOULD be 000default.local and should serve /var/www/nextcloud.site2.com/web/nextcloud/ by DocumntRoot directive - but its not!
    (the domain names have been changed to site1 and site2 to protect the innocent)
    how to achieve this worthy goal?
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

Share This Page