Odd prolem with ispconfig Debian Lenny

Discussion in 'Installation/Configuration' started by menahem, Jan 28, 2012.

  1. menahem

    menahem Member

    Hi all,

    I have a realy odd problem with ISPconfig and i will be happy to have your guidness:

    Technical data:

    Ispconfig vertion:
    Os: Debian Lenny

    Installation method:

    I was using howtoforge.net (http://www.howtoforge.com/extending-perfect-server-debian-squeeze-ispconfig-3).

    The problem:

    I have (on this server) some web sites (Vhosts). All of them working just fine except for one - let us call this one problematic.web.tld

    every once in a while - mostlly at night - problematic.web.tld srop working and if you put his URL you will get a list of files with your rowser but not the web site.

    Once this happens i log in to ispconfig managment (My case port 8080) and i see that problematic.web.tld is inactive. Geting into problematic.web.tld i see that the Avtive check box is un-checket. I check it up and web site is back to life until... Until once a again he he becomming in-active by itself.

    I do not now how that is happening.

    I am the only one who has access to ispconfig on this server,and to tj=his server at all.

    Once,at ispconfig, problematic.web.tld is in-active (not working) at /etc/apache2/sites-available i do not see sites-available vhost register as it should be.I mean: i should have problematic.web.tld.vhost at /etc/apache2/sites-available but i do not. Once i check in the Active check box at ispconfig sites interface, and once website is availableto users i do see the problematic.web.tld.vhost as needed.

    I do not know of any nightlly processs who run at this server and involved with ispconfig.

    problematic.web.tld: is high traffic web site and my clients are not happy - please do help or guide how to solve this odd problem.

    Thank you all.

  2. pititis

    pititis Member

    I know this issue. I think that your site have traffic quota exceeded. every night isconfig check the traffic quota and disable the site. Check limits for this customer (not site limits).

  3. menahem

    menahem Member


    hank you. I have made the change you suggested. Now wee have to wait to the next night quota check.

    Thank you - I will post the results.

  4. menahem

    menahem Member


    I did the changes as you suggested - it did not helped at all.

    Any more ideas.

    I found crone jobs that are running at night but they are all regarding the ispconfig log system and log rotations.

    It looks like something is running as night job but i can not put my hands on it please guide me.


  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Your installation is quite old and there were problems with the traffic quota in the past. Please update your ISPConfig installation to and then ensure that the traffic quota of that site is either set to -1 (unlimited) or to a values that is > the currently used traffic for the site.
  6. menahem

    menahem Member


    At the ispconfig manual it is suggested to the upgrade from the server command line - that is fine.
    Is there any problem to do it on a live busy server. At the manual i did not meet any restrictions as,for example,backup data base etc. are there any?
    One more thing: this server is running Debian lenny at this time i am not planning to upgrade OS - are there any rrestrictions regarding tahat?

    Thank you.
    Last edited: Jan 30, 2012
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    There should be no problem to do this on a live server. Please see here for instructions which folders and database should be backed up before you update ispconfig, just to be sure that you can revert the update in case that any problems occur:


    If you modified any config files of the services managed by ispconfig, especially postfix/dovecot/courier, then it might be nescessary that you redor your modifications after the ispconfig update.

    Debian Lenny is fine, no need to update the OS.
  8. menahem

    menahem Member

    Thank you Till.
    One more thing regarding this:
    I "only" configured files according the the howto that was published at howtoforge regarding debian lenny and ispconfig (here: http://www.howtoforge.com/perfect-server-debian-lenny-debian-5.0-with-bind-and-dovecot-ispconfig-3) - Should i reconfig it or no need?

    Thanks again.

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    You should choose to reconfigure services.
  10. menahem

    menahem Member


    Thank you.

    I just finished upgrade to current ispconfig (

    By now it looks O.K (no one called):D

    I came into one problem: Upon finishing the update I could not authenticate to my mail account. I opened Ispconfig שd admin and opened up all mail accounts and saved them - with out making any changes and mail is working just fine i.e I can sent and receive mails.

    I am planning server reboot latter on this night,and: will have to wait for tomorrow to see that the sites are all available.

    I,also, changes client traffic to -1.

    Thanks and will report latter on.

  11. menahem

    menahem Member

    Bad news

    looks like the upgrade did not helped.
    A moment ago i tried to use the particular web site and once again i got response containing a list of files but not the web site it self.

    I loged in to ispconfig as a client, clicked on sites, open website and the Active check box was nu-checked.

    Traffic Quota to this client is -1 (Un limited).

    I do have some other clients with limited quota but their web sites are working just fine.

    Some more important data:
    After ispconfig upgrade server was rebooted.
    When i look at /etc/apache2/sites-available i see that all vhosts are dated to 8/2010 exept for one - the problematic one and,unfortunately, the busiest one...
    Look at my other post: i had a problem with mail server auth - now it looks o.k.

    Please help.
    Kindl, Menahem
    Last edited: Jan 31, 2012
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats strange indeed. One thing that you can try is that you set the trafficlimit to a high numer (higher then your current monthly traffic) instead of -1. You can see the traffic of this month in the sites module.
  13. menahem

    menahem Member


    I did as you suggested.
    Now we have to wait for tomorrow.


    Let me think about a clue and share it with you:

    When the web site in un active mode (As i find it every morning) - when i log in to the server it self at /etc/apache2/sites-available the vhost file for the site is missing. Once i check in the active mode at ispconfig the vhost file,at this directory, will be created. Now: at this site there are,also,subdomains who are accessed via port 433. when the site is down i can not access the web sites using subdomain and 433.

    Technically:is you add a vhost to Apache server you need to restart the Apache service,but: once i check in the active mode at ispconfug web site is available but the Apache service did not restarted.

    What i am trying to say is:

    It looks like that ispconfig is ×™hovering above the Apache service and once the Active mode is checked out the Apache server does not really knows about it.
    The evidence for that is: once i set the website url i get a list of files but not an error coded with 4XX or 5XX error codes. As far as i remember if i will delete a vhost from /etc/apache2/sites-available and i will try to call web site url i will get site un reachable error message from apache. It is not happening in this case.

    I think we need to look for the problem at the relationships between ispconfig and the Apache server/service somewhere at this section of the implementation is miss configured or bugged or i do not know what - in any case it is not working fine.

    Another odd thing: other vhosts that at the same ip of the problematic web site are working just fine from Aug 2010.

    Another clue is:

    When i delete a web site using ispconfig interface it delete from the file system the directory where the web site was saved (ie /var/www/domain.tld etc.) and also deletes the vhost file from /etc/apache2/sites-available. In our case only the vhost file from /etc/apache2/sites-available has been deleted. So,it looks like,we have to look at this process in order to understand what is happening and why.

    Unfortunately i am not a programmer so i can not look at the code and supply with more clues - could you please try this direction and see if you can come up with something.

    Thank you.

  14. till

    till Super Moderator Staff Member ISPConfig Developer

    There is a misunderstanding on how this configuration and ispconfig work. In /etc/apache2/sites-available there are symlinks to the vhost files and not the vost files themself. You can see in ISPConfig that it works correctly, as you posted that the site was deactivated in ISPConfig and the symlink in /etc/apache2/sites-available was removed. Removing the symlink is the action which is done by activating and deactivating a site and as the site was unavailable afterwards, you see thet apache reflected the config chage correctly.

    The action to deactivate a site (changing the checkbox in the ispconfig interface which removes this symlink) is done by the script that checks the apache traffic every night. So the connection between ispconfig and apache is fine and the config reload in apache is done correctly. Apache can reload the configuration, ist does not require a restart.

    The source of the problem is something different and it is in the script that checks the traffic, if the traffic is set to -1 the acion to deactivate the site should not occur. I tested this here and sites get not disabled when traffic limit is set to -1. Mayb you could chack in the site settings again that you mixed not up web and traffic quota.
  15. menahem

    menahem Member


    Thank you for the fast replay.

    Regarding this:
    Attached output of /etc/apache2/sites-available from a virtual server running at my linux box.It is Debian 6 with ispconfig as with the prod server and look at this:(i changed user [email protected] name from the command line the rest is original)
    It look the same at the prod server and this are not symlinks.

    Now: i renamed motprg.com.vhost and removed the original. I restarted Apache service and i got :
    As it should be. That means that if,from unknown reason at night the vhost file from /etc/apache2/sites-available is deleted i should get Apache server error or browser error like this (from FF):
    and i do not.

    Can you,please,be more specific about this:
    What i have now at this client (at ispconfig) is:Web Traffic 10240 MB.

    Thanks again
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Sorry, I meant sites-enabled, not sites-available.

    You might want to check under system > server config if these settings are correct:

    vhost config dir: /etc/apache2/sites-available
    vhost config enabled dir: /etc/apache2/sites-enabled
  17. menahem

    menahem Member

    Yes it does.

  18. menahem

    menahem Member

    Fef 2nd update


    Today i 1st logged it to my server. at /etc/apache2/sites-available i found this:
    [I have changed domain name]
    1. Please note the hour that this vhost was created.

    2. I put the url at my browser and i got a list of fiels.

    3. At ispconfig interface once again this web site was not active.

    4. I activated this web site and now it is working fine.

    5. Once i activated site name i once again went to /etc/apache2/sites-available and i found this:
    [Domain name was changed]
    6. Please note the hour.

    7. Non of the other vhostat at /etc/apache2/sites-available where changed all are with the original dated they where created.

    Please guide me.

    Kind regards
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a single or multiserver installation?
  20. menahem

    menahem Member


Share This Page