Odd problem with squirrelmail

Discussion in 'Installation/Configuration' started by menahem, Apr 13, 2010.

  1. menahem

    menahem Member

    Hi all,

    I am experiencing an odd problem with squirrelmail.

    I have installed Ispconfig using this howto: http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3.

    The problem is:

    When a message sent to the local mailserver or fetched from remote mail server (Thank you till for helping solving that) is see the new message in the "inbox" of the squirrelmail, as it should be But:

    1. Leaving squirrelmail open for some time (it looks like 2 to 10 minutes) all messages in the inbox.. disappear ?!

    2. Closing squirrelmail and reopening it... all the messages from the inbox... disappear to.

    3. Only messages from the inbox disappear. Messages with **spam** go directly to "Junk", al so deleted messages stayes and ,also, messages stored at a new directory i opened at the client stay there as needed.

    To make it clear: I did not configured squirrelmail other then what was needed and as written at the howto. Also i have not touched squirrelmail interface not is conf files.

    I know this is not squirrelmail support forum but maybe someone came into this problem i have not found any of the described above at squirrelmail website.

    Any help will be highly appreciated.

    Thank you.

    Menahem
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Looks as if you use another email program that connects to your mail server and fetches the emails. Emails that were fetched with pop3 are removed from the server. Change the other email application that you use to imap if you want to keep mails on the server.
     
  3. menahem

    menahem Member

    Till,

    I do not have any other mail program that connected to this server.

    The server is behind firewall (hardware firewall) ports for pop and imap are open.

    Messages that marked as spam do arrive and stored at junk as needed.

    Messages fetched from remote server land in my inbox but after some time automatically deleted.

    I am sending to the inbox messages that where sent from this very server and this very mail account thy get into the inbox and .... disappear after some time. To make it clear: i took a message from "sent" and resent it to the same account. Seconds later i see the resent message at the inbox and.. some time later it disappears.

    From squirrelmail mailing list post i changed inbox so that it will not delete files even if i deleted them by myself. It did not helped.

    I am going to try Evoluation to see if that phenomenal reproduce it self...

    Thank you for trying.
    Menahem.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please stop the pop3 and pop3s daemon on your server and check if the messages get still deleted after some time.
     
  5. menahem

    menahem Member

    Till,
    I will do that later. For now: I sent myself a message from evaluation while squirrlmail was open in another window...
    The new message landed both on evaluation and at squirrlmail but... all the other messages from the inbox (both at squirrlmail and evalaution) gone!!!!
    Menahem
     
  6. menahem

    menahem Member

    I did it.
    Mail in the Inbox did not deleted. It is now 1 hour passed and still mail from Inbox does not disapear :) :)
    Can you please advice howto fix it??? what went wrong?

    Thank you
    Menahem
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    So the reason for the disappeared email is what I guessed in #2. There is a email client or fetchmail job that fetched your emails regularily with pop3 which caused the mails to disappear. Check the mail log for pop3 connections.
     
  8. menahem

    menahem Member

    Till,

    1st thank you for your fast replay.

    I did a search at mail.log and discovered this:
    Now: vulpes is the my server host name. the fqdn is vulpes.negrocabalo.com.

    ip=[::ffff:109.67.50.187] is: the remote computer i am writing from now and... It is the computer that i used to send receive mail using squirrlmail.

    Now: this log is odd because:
    A. i sent this mail after i stopped pop3 service. I checked it with ps aux | grep pop3* and until now this service is stopped.

    How come squirrlmail connected to my mail server over pop3? Can you please advice?
    Thank you !!!
    Menahem
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Squirrelmail uses imap and not pop3.
     
  10. menahem

    menahem Member

    Yes i know that.
    Ho do i get rid of this problem if i activate pop3 i loosing my inbox? any idea?
    Menahem
     
  11. menahem

    menahem Member

    Problem Solved

    Till,

    Thanks A lot.

    You was completely right. I had a long forgotten gmail account that was accessing my server over pop3. This was the problem. Now squirrlmail is working just fine.

    Thanks A lot.:D

    Menahem
     

Share This Page