Odd Mail problem, possible dns issue

Discussion in 'Installation/Configuration' started by darkhigh, Apr 12, 2013.

  1. darkhigh

    darkhigh New Member

    I have a strange problem with my setup. I have followed the perfect server cent os tutorial (http://www.howtoforge.com/perfect-server-centos-6.3-x86_64-apache2-courier-ispconfig-3-p5) and the server is running great. I have a domain who has an external microsoft exchange server dealing with their email Let's call them Client 1. Email is working great in all aspects except one. When a user from another domain (client 2) sends mail to the client that uses exchange(client 1) they recieve an error of .

    This is the mail system at host web2.mydomain.com.
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    For further assistance, please send mail to postmaster.
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
                       The mail system
    <user@client1'sdomain>: mail for "client1's domain" loops back to myself

    Client 2 email to outside = fine
    client 1 email to outside = fine

    client 2 email to client 1 = Error

    Any help would be appreciated.
  2. SamTzu

    SamTzu Member HowtoForge Supporter

    Looks like a DNS configuration error.

    Ask your Exchange client admin to check out what IP address their mail domain gives them?

    It probably points to a local IP address. Read about Split DNS.

Share This Page