Odd ftp issue: username defines site

Discussion in 'General' started by bidevi, Apr 24, 2010.

  1. bidevi

    bidevi New Member

    Not correct. I followed Howtoforge's perfect setup including:

    apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp

    a2enmod suexec rewrite ssl actions include

    I also select SuEXEC when creating sites in ISPConfig3.
  2. bidevi

    bidevi New Member

    There is something about this username over sitename preponderance that worries me. If I go to site2 using ftp-user1 my ftp client (FileZilla, Yummy) presents me a window named site2 while in fact I see site1.

    If those two sites have files with resembling names I might be working on the wrong site. Somehow, I still think this is not the way it should be.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats all ok. Filezilla shows you the name of the site that you enter in filezilla as FTP hostname. If it shows you another name, then you entered another name. FTP logins depend only on the username, sitenames dont matter at all. Thats defined in RFC and has nothing to do with ISPConfig. So if you wnat to know the deep internal of internet protocols, read the RFC's. You can use any domain or IP address that points to a server as FTP hostname.
  4. mike_p

    mike_p Member

    If you select SUEXEC when creating sites in ISPConfig3, then their vhost file WILL contain the SuexecUserGroup directive.

    Here are the relevant lines from the template that determine how the vhost file is written:
    <tmpl_if name='suexec' op='==' value='y'>
        # suexec enabled
        SuexecUserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'>
    If the SuexecUserGroup directive isn't present then there is something very odd going on!
  5. bidevi

    bidevi New Member

    Mike_P, you are absolutely right. I overlooked the suexec lines because I was fooled by my terminal screen (in Mac), which always has the scrollbar way down even if there is more script text below the visible part. I have to use the arrows to get there, which - this time - I did, so that is solved then.

Share This Page