Odd Errors when adding new MailServer to MultiServer

Discussion in 'ISPConfig 3 Priority Support' started by NeonTigerUK, Apr 7, 2017.

  1. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    Hi All

    I'm getting a strange error when i'm adding new server to my MultiServer Setup ....

    Code:
    root@ccmail /tmp/ispconfig3_install/install # php -q install.php
    
    >> Initial configuration 
    
    Operating System: Debian 8.0 (Jessie) or compatible
    
        Following will be a few questions for primary configuration so be careful.
        Default values are in [brackets] and can be accepted with <ENTER>.
        Tap in "quit" (without the quotes) to stop the installer.
    
    Select language (en,de) [en]:
    
    Installation mode (standard,expert) [standard]: expert
    
    Full qualified hostname (FQDN) of the server, eg server1.domain.tld  [ccmail.domain.tld]:
    
    MySQL server hostname [localhost]:
    
    MySQL server port [3306]:
    
    MySQL root username [root]:
    
    MySQL root password []: xxxxxxxxxxxxxxxxx (correct passed for ccmail mysql root user)
    
    MySQL database to create [dbispconfig]:
    
    MySQL charset [utf8]:
    
    The next two questions are about the internal ISPConfig database user and password.
    It is recommended to accept the defaults which are 'ispconfig' as username and a random password.
    If you use a different password, use only numbers and chars for the password.
    
    ISPConfig mysql database username [ispconfig]:
    
    ISPConfig mysql database password [...usual random string...]:
    
    Shall this server join an existing ISPConfig multiserver setup (y,n) [n]: y
    
    MySQL master server hostname []: web1.domain.tld
    
    MySQL master server port []:
    
    MySQL master server root username [root]:
    
    MySQL master server root password []:  yyyyyyyyyyyyyy (correct passed for web1 mysql root user)
    
    MySQL master server database name [dbispconfig]:
    
    Unable to connect to mysql server Access denied for user 'root'@'ccmail.domain.tld' (using password: NO)
    
    I have added the required entries into the mysql on web1 as per

    Code:
    CREATE USER 'root'@'192.168.1.109' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.0.109' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'mail.example.tld' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'mail.example.tld' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    Changed IP addresses for Correct ones and mail.example.tld for correct FQDN

    Thanks In Advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can test it with the mysql command on the slave:

    mysql -h web1.domain.tld -u root -p

    if this works, then the installer should work too. If it fails, then you have to check the permissions / settngs on the master and adjust them until you are able to login and then try the ISPConfig installation again.
     
  3. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    it can't log in - however its worked previously when Ive added new servers ......

    tried it on one of the existing servers, and it isnt working either with the same password, although logging into phpmyadmin is ok with the same password ... getting confused now
     
  4. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    SOLVED, its me being a bit thick, I was trying the root mysql user password of `web1` rather than the root password i set in the creation of the user _on_ `web1`
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the /etc/hosts files on all servers. Maybe the hostnames resolve to the external IP's now instead of the internal ones.
     

Share This Page