NVIDIAnForce3 AC97 sound issue

Discussion in 'Installation/Configuration' started by CiscoLV, Sep 13, 2007.

  1. CiscoLV

    CiscoLV New Member

    I'm new and I need help. Could someone please tell me in laymens terms how to install the Nforce3 drivers? I have onboard sound, NvidianForce3 series. The cd contains Linux drivers, however I am lost when it comes to installing/setting them up!
    Here is what the readme file states: The source code copy from www.alsa-project.org. ver:A2.5
    Linux Source Code for ALC audio codec

    Installation:
    This Source Code is from www.alsa-project.org.
    For driver installation, please follow below steps.

    Step 1. unzip source code
    tar xfvj alcsound.tar.bz2

    Step 2. Turn on sound support (soundcore module, default turn on)

    Step 3. Complied source code
    a. ./configure
    b. make
    c. make install
    d. ./snddevices

    Step 4. Edit your /etc/modules.conf or conf.modules depending on the distribution
    (Please refer to the attached modules.conf)

    Step 5. reboot your machine

    Note: 1. The most detail information, can refer the alsa-kernel/Documenttation/ALSA-Configuration.txt
    in the alcsound.tar.bz2.
    2. Kernel Version must be 2.2.14 or later.
    3. All mixer channels are muted by default. You must use a native
    or OSS mixer program to unmute appropriate channels.
    4. If can not compile the source code, try to rename the /usr/src/linux-2.x -> /usr/src/linux.
    5. The driver added to support the SPDIF functoin.
    6. Suggest use alsamixer to control mixer function. you can find it in the alsa-utils-0.9.4 (www.alsa-project.org).
    __________________________________________________________________________________________________ could someone give me some tips in laymen terms please? Thanks ahead of time.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Place alcsound.tar.bz2 in some directory, e.g. /tmp, and run
    Code:
    cd /tmp
    tar xfvj alcsound.tar.bz2
    Not sure what this means. Maybe it just means that your sound card must be built in before you try to compile alcsound.

    After you've unpacked alcsound.tar.bz2, go to its directory (probably something like
    Code:
    cd alcsound
    ) and run
    Code:
    ./configure
    make
    make install
    ./snddevices
    As far as I understand, you should have a sample modules.conf somewhere and change your /etc/modules.conf according to this sample.

    Run
    Code:
    shutdown -r now
     
  3. CiscoLV

    CiscoLV New Member

    Vielen Danke Falco

    I used to live in a small town named Imsbach, my Dad was at Sembach Luftwaffe base.
    At one time I was fluent in German too! I lived there 5 yrs and loved it! (I am half German ---Mueller) by birth.
    I am extremely impressed w/ your computer education!
    I am still unable to play sound however. Again, I am running SuSE 10.2 and I am using the Nvidia chipset cd/drivers cd. I tried all the unzipping etc. to no avail. is there an EASIER way?! when I tried the ./install, nogo, when I tried make.....same
    what am I doing wrong please.
    Danke Schoene
    CiscoLV:confused:
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Would it be an option for you to update to OpenSUSE 10.3 (which has just been released)? I guess it has much better hardware support than 10.2. :)
     

Share This Page