nullmailer smtp protocol error

Discussion in 'Server Operation' started by gabrix, Nov 19, 2006.

  1. gabrix

    gabrix New Member

    Nov 19 15:03:54 localhost nullmailer[5013]: smtp: Failed:
    Nov 19 15:03:54 localhost nullmailer[2801]: Sending failed:  Protocol error
    Logcheck from the gateway machine is not sending me mails anymore and mail logs don't say more than this smtp protocol error , so idn't know ehere to go and look for this smtp protocol error ... any clue anyone ???
  2. gabrix

    gabrix New Member

    Do you know an alternative to nullmailer ????
    I have installed swaks which is supposed to troubleshot mail agent problems and tha's what it says:
    I have 2 dns in my network one is my netgear router the other is dnsmasq which listen on the lan eth1 interface and they are both in the /etc/resolv.conf togheter with the 2 of my isp !
    It's getting even stranger my local smtp behavior i deliver mail from internet and none from local smtp (i have nullmailer on all machines).I had an another go with swaks (nice prog!)
    I delivered this mail so i tryied using mail smtp client and no mail has been delivered ...
    The DNS problem is proved by that MAIL FROM:<[email protected]>
    Last edited: Nov 19, 2006
  3. gabrix

    gabrix New Member

    I got over this problem installing a new local smtp , ssmtp ... nice this prog too.Strange is nullmailer too . it always worked and it doesn't have configurations issues !
  4. borisba

    borisba New Member

    I have same problem

    When I send e-mail from to SMTP server:

    [05-Mar-2013 13:31:45] Tue, 05 Mar 2013 13:31:42> OnReceive - SMTP Server
    [05-Mar-2013 13:31:45] EHLO
    [05-Mar-2013 13:31:45] Hello [xx.xx.xx.xx], pleased to meet you!

    [05-Mar-2013 13:31:45] 250-8BITMIME

    [05-Mar-2013 13:31:45] 250 HELP

    [05-Mar-2013 13:31:45] mail oa0
    [05-Mar-2013 13:31:45] 250 3.1.0 <>... Google Sender ok

    [05-Mar-2013 13:31:45] Tue, 05 Mar 2013 13:31:45> OnReceive - SMTP Server
    [05-Mar-2013 13:31:45] MAIL FROM <[email protected]>
    [05-Mar-2013 13:31:45] 250 2.1.0 <[email protected]>... Sender ok

    [05-Mar-2013 13:31:45] QUIT
    [05-Mar-2013 13:31:45] 221 Service closing transmission channel

    [05-Mar-2013 13:31:45] ResetConnection.
    [05-Mar-2013 13:31:45] m_bBlockAccept = FALSE
    [05-Mar-2013 13:31:45] SMTP OnMessageResetConnection - ResetConnection()
    Why gmail send QUIT suddenly? ( Instead RCPT TO -> DATA)
  5. borisba

    borisba New Member

    I've solved this.
    The reply to string
    mail oa0
    is unnecessary.

Share This Page