Ntop 4 on Ubuntu

Discussion in 'Installation/Configuration' started by kelmos, Aug 4, 2010.

  1. kelmos

    kelmos New Member

    Hi,

    Has anyone compiled NTOP 4 on their systems yet? I've installed all dependencies and yet still get errors.

    Ubuntu Server 8.04
    NTOP 4
    Python 2.7

    Problem:
    When running ./configure for ntop, I get an error, or warning, stating that Python 2.6 or newer needs to be installed.

    I've installed Python 2.6.4 and then 2.6.5 and then ended up with 2.7.

    Here's what happens after running "make" for Ntop:

    Anyone else got this problem before? If so, how did you manage to fix it?

    I don't want to install Python3 just yet as I don't know if Ntop will support it yet.

    Thanks,
    K
     
  2. falko

    falko Super Moderator

    Please install python-all-dev and try again.
     
  3. kelmos

    kelmos New Member

    It's not the first time something gets fixed by one small dependency.

    Thanks Falko.
     

Share This Page