ns installation wont let me do it on ubuntu 9.10

Discussion in 'Installation/Configuration' started by foottuns, Nov 2, 2009.

  1. foottuns

    foottuns New Member

    Helllo there, I don't know if here is the place but I am trying to configure ns on my system, I saw a few tutorials which they were interested and good, but all the time when I try to compile the ns source I get this error and I don't know what should I do to fix it.

    Error

    Code:

    Code:
    
    checking for a BSD-compatible install... /usr/bin/install -c
    checking system version (for dynamic loading)... Linux-2.6.31-14-generic
    No explicit static compilation flag; setting V_STATIC to ""
    checking for dlopen in -ldl... yes
    checking for a BSD-compatible install... /usr/bin/install -c
    configure: creating ./config.status
    config.status: creating Makefile
    rm -f libotcl.so otcl.o so_locations
    gcc -c -g -O2 -DNDEBUG -DUSE_SHM -fpic -I. -I/home/bogdan/ns/ns-allinone-2.34/include -I/home/bogdan/ns/ns-allinone-2.34/include -I/home/bogdan/ns/ns-allinone-2.34/include -I/include  otcl.c
    ld -shared -o libotcl.so otcl.o
    otcl.o: In function `OTclDispatch':
    /home/bogdan/ns/ns-allinone-2.34/otcl-1.13/otcl.c:495: undefined reference to `__stack_chk_fail_local'
    otcl.o: In function `Otcl_Init':
    /home/bogdan/ns/ns-allinone-2.34/otcl-1.13/otcl.c:2284: undefined reference to `__stack_chk_fail_local'
    ld: libotcl.so: hidden symbol `__stack_chk_fail_local' isn't defined
    ld: final link failed: Nonrepresentable section on output
    make: *** [libotcl.so] Error 1
    otcl-1.13 make failed! Exiting ...
    See http://www.isi.edu/nsnam/ns/ns-problems.html for problems
    
    
     
  2. till

    till Super Moderator

    As far as I can see, the compile output you posted is not from mydns and mydns is currently the only supported dns server of ispconfig 3 stable versions.
     
  3. foottuns

    foottuns New Member

    the problem has been sort it out, now is working perfectly, soon i will write a tutorial how i did it and i will add it here....
     
  4. pdro7

    pdro7 New Member

    otcl problem on ubunto 9.X

    foottuns how did u resolve the problem?? i'm having it now =(
     
  5. LakeEffect

    LakeEffect New Member

    otcl problem on ubuntu 9.10

    This error is because the linker being used is "ld -shared" instead of "gcc -shared". If you edit one line in otcl-1.1*/configure, and rerun install, it should work:

    --- configure.orig 2009-11-02 12:14:52.556167945 -0800
    +++ configure 2009-11-02 12:17:28.966706099 -0800
    @@ -6301,7 +6301,7 @@
    ;;
    Linux*)
    SHLIB_CFLAGS="-fpic"
    - SHLIB_LD="ld -shared"
    + SHLIB_LD="gcc -shared"
    SHLIB_SUFFIX=".so"
    DL_LIBS="-ldl"
    SHLD_FLAGS=""
     

Share This Page