Nothing Output from Munin

Discussion in 'Installation/Configuration' started by mdittmer, Jan 7, 2009.

  1. mdittmer

    mdittmer New Member

    I recently installed munin to see how it runs on Ubuntu. I configured it to only monitor the machine it is running on (localhost.localdomain). It appears that both munin and munin-node are running properly, except no reports are showing up on munin's page. There is a page for localhost.localdomain but it contains no reports. Munin has been running for over a day now, and the generated by Munin message at the bottom suggests that it is updating at regular intervals.

    Here is some relevant configuration information

    munin.conf
    Code:
    dbdir   /var/lib/munin
    htmldir /var/www/munin
    logdir  /var/log/munin
    rundir  /var/run/munin
    tmpldir /etc/munin/templates
    graph_strategy cgi
    [localhost.localdomain]
        address 127.0.0.1
        use_node_name yes
    munin-node.conf
    Code:
    log_level 4
    log_file /var/log/munin/munin-node.log
    pid_file /var/run/munin/munin-node.pid
    background 1
    setseid 1
    user root
    group root
    setsid yes
    ignore_file ~$
    ignore_file \.bak$
    ignore_file %$
    ignore_file \.dpkg-(tmp|new|old|dist)$
    ignore_file \.rpm(save|new)$
    ignore_file \.pod$
    allow ^127\.0\.0\.1$
    host 127.0.0.1
    port 4949
    Munin virtual host configuration on Apache 2
    EDIT: Fixed mismatch in cgi-bin location; still no success
    Code:
    <VirtualHost *:80>
            ServerAdmin webmaster@localhost
            ServerName munin
    
            DocumentRoot /var/www/munin
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    
            ScriptAlias /cgi-bin/ /var/www/munin/cgi-bin/
            <Directory "/var/www/munin/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog /var/log/apache2/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel notice
    
            CustomLog /var/log/apache2/access.log combined
    
            ServerSignature On
    </VirtualHost>
    As you can see, I'm attempting to configure Munin to use just-in-time reporting via CGI by following these instructions without bothering with fast CGI.

    Any suggestions as to why Munin might appear to be doing its job but also appear to be configured to provide 0 reports?
     
    Last edited: Jan 7, 2009
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    ls -la /var/www/munin
    ?

    Are there any errors in your logs?
     
  3. mdittmer

    mdittmer New Member

    I don't see any errors. I noticed (after my last post) that cgi-bin/munin-cgi-graph was in /var/lib/cgi-bin (not in /var/www/munin/cgi-bin), so I moved it, chowned it to munin:www-data, and made sure it was executable. Even with restarting munin and/or munin-node this did not solve any problems.

    Code:
    $ ls -la /var/www/munin
    total 32
    drwxr-xr-x 4 munin munin    4096 2009-01-07 09:55 .
    drwxr-xr-x 3 root  root     4096 2009-01-06 14:44 ..
    drwxrwxr-x 2 munin www-data 4096 2009-01-07 11:18 cgi-bin
    -rw-r--r-- 1 munin munin    2555 2009-01-06 14:15 definitions.html
    -rw-r--r-- 1 munin munin    1217 2009-01-08 08:40 index.html
    drwxrwxr-x 2 munin www-data 4096 2009-01-06 14:15 localdomain
    -rw-r--r-- 1 munin munin     473 2009-01-06 14:15 logo.png
    -rw-r--r-- 1 munin munin    3538 2009-01-06 14:15 style.css
    I got no output from

    Code:
    $ sudo grep -i error /var/log/munin/*
    Viewing the logs manually doesn't seem to suggest anything out of the ordinary either. Any suggestions?
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    ls -la /var/lib/munin/
    ?
     
  5. mdittmer

    mdittmer New Member

    Code:
    $ ls -la /var/lib/munin
    total 28
    drwxr-xr-x  3 munin munin 4096 2009-01-12 08:50 .
    drwxr-xr-x 65 root  root  4096 2009-01-07 09:52 ..
    -rw-r--r--  1 munin munin  254 2009-01-12 08:50 datafile
    -rw-r--r--  1 munin munin   14 2009-01-12 08:50 limits
    -rw-r--r--  1 munin munin   76 2009-01-06 15:45 munin-graph.stats
    -rw-r--r--  1 munin munin  154 2009-01-12 08:50 munin-update.stats
    drwxrwxr-x  2 munin munin 4096 2008-08-06 08:47 plugin-state
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Looks ok as well. Did you disable AppArmor?
     

Share This Page