not secure

Discussion in 'ISPConfig 3 Priority Support' started by Tom John, Mar 30, 2020.

  1. Tom John

    Tom John Member HowtoForge Supporter

    Hi Guys,
    we had a chat about not secure here:
    https://www.howtoforge.com/community/threads/not-secure.82581/
    I use ISPConfig 3.1, Ubuntu 18.04
    with the domain casting-canarias.com i have
    - a valid SSL Certificate
    - and put redirect from http to https as well.
    But however there is a "not secure" in the browser..
    Did i make something wrong?
    thanks for your kind help again
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This message is e.g. shown by a web browser if the HTML of an https website contains references to content elements by http.
     
  3. Tom John

    Tom John Member HowtoForge Supporter

    Hi and thank you for your kind answer.
    The website is a wordpress website, and i can see it show https://
    www.casting-canarias.com
    How i can find out where is a reference to http elements?
    its a new standard installation of wordpress so i assume all is in https://
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Open the website in a browser, then choose to view the HTML code (this function is offered by all browsers) and there search for http:// in the sourcecode. If you find places where http:// is used, change that in the code or template of your website.

    These HTTP:// elements are probably not from WordPress itself, they are either from a theme, a wrong WordPress setting or a plugin
     
  5. elmacus

    elmacus Active Member HowtoForge Supporter

    You can change ALL media links for Wordpress in A HREF from HTTP://example.net/image.png to
    //example.net/image.png
    That way all pictures work in both HTTP and HTTPS.
     
  6. Tom John

    Tom John Member HowtoForge Supporter

    i found in js something:
    Code:
    <script type='https://mask1000.com/wp-content/plugins/woocommerce/assets/js/frontend/single-product.min.js?ver=4.0.1'></script>
    <script type='https://mask1000.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
    <style id="et-core-unified-17-cached-inline-styles-2">div.et_pb_section.et_pb_section_0{background-image:url(http://mask1000.com/wp-content/uploads/2020/03/1585414466605.jpg)!important}.
    
    https://www.mask1000.com/ on the home ... website
    do i need an update of js?
    or can i change this in the js file directly?
    thanks a lot for your kind help
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you changed Wordpress site url and home url to https?
    If that does not help, you have to find where that http link comes from and fix it there.
     
  8. Tom John

    Tom John Member HowtoForge Supporter

    Hi guys,
    thanks for your kind answer.
    i change wordpress already to https://
    all links of the pictures in media are https:// but when i see the source code in browser i can see the pictures have http://
    how can i change from http to https even in the media all pic have https:// already..
    any idea?
    or would it be helpful i delete all picture and upload them again?
    thanks for your kind help
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use a cache in WordPress? If yes, the wrong URL might be cached.
     
  10. Tom John

    Tom John Member HowtoForge Supporter

    Hi,
    thanks for your quick answer.
    i dont use cache, but i just did install wp super cache for delete all cache.
    after deleting cache its still the same
    for me its possible to delete all pictures and set them new if that would be a solution that helps...
    thanks for your help
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    I don't think that deleting pictures will help. Double-check in wp-settings, if I remember correctly you have to change the URL of the site in 2 places in the settings to https://
     
  12. Tom John

    Tom John Member HowtoForge Supporter

    Hi,
    thanks for your kind help.
    i check there are 2 URLS in wordpress:
    Wordpress Address URL
    Site Address URL
    both are correct.

    the other solution i see is to install all new and see when the error appears.
    i am really greatful you help me with this matter, actually i should have looked before and pay attention when the not secure error occurs.

    UPDATE: I just checked with one page if i delete the pic and upload a new pic then no error occurs so i check more and keep you update.... in the meanwhile thanks a lot
     
    Last edited: Apr 2, 2020
  13. Tom John

    Tom John Member HowtoForge Supporter

    I found the solution.
    I deleted the pictures and upload new pictures, so the problem was solved.
    I thank you so much for help me with this matter
    i am grateful as always
     
    till likes this.

Share This Page