not secure

Discussion in 'ISPConfig 3 Priority Support' started by Tom John, Aug 14, 2019.

  1. Tom John

    Tom John Member HowtoForge Supporter

    Hi Guys,
    i am using ISPConfig 3 and Ubuntu 18.04
    I activate SSL in ISPConfig so there is no red warning about not secure but there is a no secure before the URL and i wonder why because i use a valid SSH certificate
    I use wordpress for this website.
    this is the website: www.free-invoice.net
    maybe you have an idea why i get an not secure
    thanks for your kind help
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You get a not secure message when you enter http://www.free-invoice.net instead of https://www.free-invoice.net. Enable the http to https redirect on the redirect tab of the website if you want that users that access your site by http get redirected to https automatically. And ensure that you changed all url's in wordpress config settings from http to https.
     
  3. Tom John

    Tom John Member HowtoForge Supporter

    thanks for you kind answer.
    In ISPConfig i go to website then i see the redirect tab, but in the tab i find only R,L redirect, what should i put into the redirect pass?
    I dont find a redirect http to https tab
    so i choose your solution to add in apache directives:
    Code:
    RewriteEngine on
    RewriteCond %{SERVER_PORT} !^443$
    RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [L,R] 
    
    
    that works but however i wonder where is the redirect flag http to https
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, there is a checkbox for that on the redirect tab, labeled "Rewrite HTTP to HTTPS".
     
  5. Tom John

    Tom John Member HowtoForge Supporter

    Hi and thanks for your kind answer.
    Yes it works, thats great and thanks for your kind help
     

Share This Page