Not receiving mail

Discussion in 'Installation/Configuration' started by SamDenton, Mar 1, 2006.

  1. SamDenton

    SamDenton New Member

    I have installed The perfect Fedora setup, then installed ISPConfig.

    My problem is now, that I have set up some users but none can receive emails, they can all send, but none can receive.

    The Maillog shows:

    Mar 1 11:46:00 ds-r1060025-001 postfix/local[14167]: 6818B82010C: to=<web3_sam@ds-r1060025-001.redstation.co.uk>, orig_to=<sam@imagemachinery.com>, relay=local, delay=3, status=sent (delivered to command: /usr/bin/procmail -f-)
    Mar 1 11:46:00 ds-r1060025-001 postfix/qmgr[12592]: 6818B82010C: removed

    But theres nothing to download in any inbox.

    Any ideas? If you need more information let me know!

    Thanks

    Sam
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you choose the correct value for Maildir under Management -> Server -> Settings -> Email?
    Please post the output of
    Code:
    netstat -tap
     
  3. SamDenton

    SamDenton New Member

    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 19020/xinetd
    tcp 0 0 *:32769 *:* LISTEN 1575/rpc.statd
    tcp 0 0 *:pop3s *:* LISTEN 19020/xinetd
    tcp 0 0 *:mysql *:* LISTEN 3224/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 19020/xinetd
    tcp 0 0 *:imap *:* LISTEN 19020/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 1558/portmap
    tcp 0 0 *:81 *:* LISTEN 23098/ispconfig_htt
    tcp 0 0 mail.etruscarestaura:domain *:* LISTEN 23209/named
    tcp 0 0 ds-r1060025-001:domain *:* LISTEN 23209/named
    tcp 0 0 ds-r1060025-001:ipp *:* LISTEN 1880/cupsd
    tcp 0 0 ds-r1060025-001:5335 *:* LISTEN 1864/mDNSResponder
    tcp 0 0 ds-r1060025-001:rndc *:* LISTEN 23209/named
    tcp 0 0 *:smtp *:* LISTEN 23181/master
    tcp 0 0 mail.etruscarestaurant:pop3 host86-140-42-162.rang:4013 TIME_WAIT -
    tcp 0 0 mail.etruscarestaurant:pop3 host86-140-42-162.rang:4009 TIME_WAIT -
    tcp 0 0 *:ssh *:* LISTEN 1969/sshd
    tcp 0 0 ::1:rndc *:* LISTEN 23209/named
    tcp 0 2596 mail.imagemachinery.com:ssh redstation-116.adsl.n:32522 ESTABLISHED 5212/0
     
  4. SamDenton

    SamDenton New Member

    Okay I reinstalled postfix and then ISPConfig as recommended elsewhere and now I get the following

    Mar 1 13:33:10 ds-r1060025-001 postfix/smtpd[23661]: connect from redstation-117.adsl.newnet.co.uk[81.3.109.117]
    Mar 1 13:33:10 ds-r1060025-001 postfix/smtpd[23661]: NOQUEUE: reject: RCPT from redstation-117.adsl.newnet.co.uk[81.3.109.117]: 554 <test@imagemachinery.com>: Relay access denied; from=<samdenton@redstation.com> to=<test@imagemachinery.com> proto=ESMTP helo=<exchange.redstationfec.co.uk>
    Mar 1 13:33:10 ds-r1060025-001 postfix/smtpd[23661]: disconnect from redstation-117.adsl.newnet.co.uk[81.3.109.117]

    however test@imagemachinery.com is in the /etc/postfix/virtusertable and imagemachinery.com is in the /etc/postfix/local-host-names

    Thanks again

    Sam
     
  5. SamDenton

    SamDenton New Member

    Okay Sorted the Relay-Denied message now...

    Back to the first issue... The server appears to accept mail but its just not being picked up by user accounts.

    Any more info I can give you to get this sorted?

    Thanks

    Sam
     
  6. SamDenton

    SamDenton New Member

    Errr... I don't get an option to change the maildir from here? Only a tick box?

    Thanks

    Sam
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Your POP3 daemon uses the mbox format which means you must disable Maildir under Management -> Server -> Settings -> Email.
     

Share This Page