not receiving emails. emails bouncing back

Discussion in 'Installation/Configuration' started by munika, Jan 25, 2007.

  1. munika

    munika New Member

    hi guys,
    first of all thanks for all the help for installation with the previous box. i have started installation on a new box.

    I have a p3 533 mhz pc with 512 mb ram and 10gb hard disk. I installed FC5 followed the perfect setup for fedora core 5 from the howtoforge website. Then i downloaded the ispconfig and followed the instructions and installed ispconfig. No Problems till this step.

    i have a machine with kerio winroute which works as a firewall/router. i have public ips comming to it and from there the kerio software maps it to a local ip address(192.168.0.14). i have kept all the ports open just to be sure there isnt any problem.

    i have a domain name www.keshwani.net which i got from 1and1.com i have changed the a record and the mx record and set the priority to 11 from 1and1 control panel.

    http works fine and i get the default index page. i tried ftping to www.keshwani.net through a user([email protected], web1_munir) changed the index.html works perfectlyfine.

    the problem is with email.
    i used mozilla thunderbird as email client and did all the settings.
    i am able to send email to outside world eg. gmail or hotmail.
    when somebody tries to send email to [email protected] it bounces back. and the sender gets a error message attached in details.txt

    a maillog is also attached.

    if somebody could tell me why is access denied and how can i fix it.

    thankyou.

    munika
     

    Attached Files:

    Last edited: Jan 26, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    Is your new box test.keshwani.net?
    What's in /etc/postfix/main.cf (please strip out the comments) and /etc/postfix/local-host-names?
     
  3. munika

    munika New Member

    new box not receiving emails

    yes that is right.
    my new box is test.keshwani.net

    i am attaching both the files with this reply.

    thankyou for your prompt reply

    munika
     

    Attached Files:

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please add a co-domain keshwani.net (with empty host field) to the website www.keshwani.net.
     
  5. munika

    munika New Member

    thankyou very much

    thankyou very much it works fine.

    can i know what was the problem.

    also can i know how i can create mail.keshwani.net which will be a webmail for keshwani.net i have other domains too which i am planning to move to this server and they will have their own mail co-domain.

    any suggestions as to which webmail software should i use and how to implement it.
    thanks




    munika
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Postfix knew www.keshwani.net, but not keshwani.net, that's why mails bounced. Technically spoken, keshwani.net and www.keshwani.net are two totally different FQDNs.

    Just install one of the webmail packages from http://www.ispconfig.org/downloads.htm (Uebimiau or Squirrelmail), or take a look here:
    http://www.howtoforge.com/squirrelmail_ispconfig
    http://www.howtoforge.com/roundcube_webmail_ispconfig
    http://www.howtoforge.com/ilohamail_ispconfig
     

Share This Page