Not receiving any incoming mail.

Discussion in 'General' started by Jcorrea920, Mar 4, 2006.

  1. Jcorrea920

    Jcorrea920 New Member

    So I haven't recevied any incoming mails this month. Fedora Core 4 Perfect Setup although I update software about once a month.
    my /var/log/maillog file show this:
    Code:
    Feb 26 01:30:02 ccs02 postfix/smtpd[626]: disconnect from ccs02.correaconsulting.com[127.0.0.1]
    Feb 26 01:30:02 ccs02 ipop3d[629]: pop3 service init from 127.0.0.1
    Feb 26 01:30:02 ccs02 ipop3d[629]: Command stream end of file while reading line user=??? host=UNKNOWN
    Feb 26 01:33:22 ccs02 postfix/anvil[627]: statistics: max connection rate 1/60s for (smtp:127.0.0.1) at Feb 26 01:30:02
    Feb 26 01:33:22 ccs02 postfix/anvil[627]: statistics: max connection count 1 for (smtp:127.0.0.1) at Feb 26 01:30:02
    Feb 26 01:33:22 ccs02 postfix/anvil[627]: statistics: max cache size 1 at Feb 26 01:30:02
    Feb 26 02:00:01 ccs02 postfix/smtpd[1120]: connect from ccs02.correaconsulting.com[127.0.0.1]
    Feb 26 02:00:01 ccs02 postfix/smtpd[1120]: lost connection after CONNECT from ccs02.correaconsulting.com[127.0.0.1]
    Feb 26 02:00:01 ccs02 postfix/smtpd[1120]: disconnect from ccs02.correaconsulting.com[127.0.0.1]
    Feb 26 02:00:01 ccs02 ipop3d[1123]: pop3 service init from 127.0.0.1
    Feb 26 02:00:01 ccs02 ipop3d[1123]: Command stream end of file while reading line user=??? host=UNKNOWN
    @
    
    my postconf -n:
    Code:
    [postmaster@ccs02 ~]$ postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    broken_sasl_auth_clients = yes
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    daemon_directory = /usr/libexec/postfix
    home_mailbox = maildir/
    html_directory = no
    inet_interfaces = all
    local_recipient_maps = hash:/etc/postfix/local_recipients
    mail_owner = postfix
    mail_spool_directory = /var/spool/mail/
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
    mydomain = correaconsulting.com
    myorigin = $mydomain
    newaliases_path = /usr/bin/newaliases.postfix
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
    relay_recipient_maps = hash:/etc/postfix/relay_recipients
    sample_directory = /usr/share/doc/postfix-2.2.2/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    smtp_tls_note_starttls_offer = yes
    smtp_use_tls = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom
    unknown_local_recipient_reject_code = 550
    virtual_alias_domains = hbriggs.com, correaconsulting.com.mx, sandyoptimistclub.org, sthenrygresham.org
    virtual_alias_maps = hash:/etc/postfix/virtusertable
    
    I got a complaint about a month ago that once of my clients could not send or receive emails outside the local network. So I started fooling around with the main.cf file bad idea because I think I took the / out of the Maildir/ and /var/spool/mail/ accidently converting Maildir to mboxes, so I tried to convert everything back to Maildir even checking the Maildir checkbox on ISPConfig Administrative Management. We can send mail out. But receiving mail in is another story. I have gone to many forums on many sites looking for clues but not very successful. I even hired a consultant to look at it and he said it works fine. Could it be my file permissions?
    my /var/spool/mail directory permissions:
    Code:
    drwxrwxr-x   2 root   mail    4096 Feb 27 22:04 mail
    
    my /var/spool/mail/* permissions:
    Code:
    -rw-------  1 admispconfig       mail     0 Sep 15 15:38 admispconfig
    -rw-------  1 root               root 24020 Sep 17 04:02 root
    -rw-------  1 web18_admin        mail     0 Sep 28 18:25 web18_admin
    -rw-------  1 web18_jorge        mail     0 Sep 28 18:26 web18_jorge
    -rw-------  1 web21_admin        mail     0 Dec  9 22:29 web21_admin
    -rw-------  1 web21_bob          mail     0 Jan 31 12:20 web21_bob
    -rw-------  1 web26_harold       mail   566 Feb 21 09:18 web26_harold
    -rw-------  1 web30_admin        mail     0 Feb 17 15:54 web30_admin
    -rw-------  1 web3_alejandro     mail   566 Feb 27 15:20 web3_alejandro
    -rw-------  1 web3_alma          mail   566 Feb  3 15:52 web3_alma
    -rw-------  1 web3_analaura      mail  1799 Feb 14 14:04 web3_analaura
    -rw-------  1 web3_diana         mail   566 Feb 16 12:46 web3_diana
    -rw-------  1 web3_gladys        mail   566 Nov 29 12:30 web3_gladys
    -rw-------  1 web3_javier        mail   566 Feb 20 17:16 web3_javier
    -rw-------  1 web3_jorge         mail  2818 Mar  3 14:29 web3_jorge
    -rw-------  1 web3_jorgedelarosa mail   566 Feb 10 08:22 web3_jorgedelarosa
    -rw-------  1 web3_judith        mail   566 Feb 14 13:39 web3_judith
    -rw-------  1 web3_lucero        mail 12632 Feb 14 14:05 web3_lucero
    -rw-------  1 web3_sandra        mail   566 Feb 21 09:18 web3_sandra
    
    1. How can I fix Maildir/ if possible?
    2. Do I need delete all the /cur, /new, /tmp directories and try Mboxes? If so how should I do this?
    3. Or do I need to update to the new version of ISPConfig? Can that be done?
    Would appreciate help if you can:confused:
     
  2. falko

    falko Super Moderator

    You're using Maildir, but you have a POP3 daemon that relies on the mbox format. That doesn't work. I suggest you install Dovecot; Dovecot is a POP3/IMAP daemon that uses Maildir.

    And
    Code:
    home_mailbox = maildir/
    should be
    Code:
    home_mailbox = Maildir/
    in /etc/postfix/main.cf.
     
  3. Jcorrea920

    Jcorrea920 New Member

    Dovecot already installed

    Falko,
    Thanks for your quick response, but Dovecot is already installed.
    Code:
    [root@ccs02 ]# dovecot --version
    0.99.14
    
    How can I fix my problem of no incoming mail?
     
  4. falko

    falko Super Moderator

    Dovecot might be installed, but it isn't running. Currently your POP3 daemon is ipop3d which uses mbox format.
    You must stop ipop3d and then start Dovecot.
     
  5. Jcorrea920

    Jcorrea920 New Member

    How do I stop ipop3d?

    Falko,
    thanks for the advise, I know how to start dovecot
    Code:
    /etc/init.d/dovecot start
    But how on earth do I stop ipop3d without stopping xinetd or named?

    Jorge:(
     
  6. Jcorrea920

    Jcorrea920 New Member

    Stopping ipop3d?

    I must have the wrong commands. I tried:
    Code:
    [root@ccs02 home]# /sbin/chkconfig ipop3d off
    error reading information on service ipop3d: No such file or directory
    
    what would work with my situation? should I turn xined off?:eek:
     
  7. Jcorrea920

    Jcorrea920 New Member

    Slowing fixing the issue

    Falko,
    I found the command on the forum and now this is what I get:
    Code:
    [root@ccs02 ]# chkconfig ipop3 off
    [root@ccs02 ]# service dovecot start
    Starting Dovecot Imap: Fatal: listen(143) failed: Address already in use
                                                               [FAILED]
    [root@ccs02 ]# /etc/init.d/dovecot start
    Starting Dovecot Imap: Fatal: listen(143) failed: Address already in use
                                                               [FAILED]
    
    So I wanted to know what is using the imap port 143 and of coarse so I ran a netstat:
    Code:
    [root@ccs02 ]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    [COLOR="red"]tcp        0      0 *:imaps                     *:*                         LISTEN      1723/xinetd[/COLOR]
    tcp        0      0 *:32769                     *:*                         LISTEN      1451/rpc.statd
    tcp        0      0 *:pop3s                     *:*                         LISTEN      1723/xinetd
    tcp        0      0 *:mysql                     *:*                         LISTEN      1813/mysqld
    [COLOR="Red"]tcp        0      0 *:imap                      *:*                         LISTEN      1723/xinetd[/COLOR]
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      1434/portmap
    tcp        0      0 *:81                        *:*                         LISTEN      2109/ispconfig_http
    tcp        0      0 *:ftp                       *:*                         LISTEN      3765/proftpd: (acce
    tcp        0      0 10.79.33.186:domain         *:*                         LISTEN      2386/named
    tcp        0      0 smtp.correaconsultin:domain *:*                         LISTEN      2386/named
    tcp        0      0 10.79.33.50:domain          *:*                         LISTEN      2386/named
    tcp        0      0 ccs02.correaconsulti:domain *:*                         LISTEN      2386/named
    tcp        0      0 ccs02.correaconsulting.:ipp *:*                         LISTEN      3855/cupsd
    tcp        0      0 ccs02.correaconsulting:5335 *:*                         LISTEN      1664/mDNSResponder
    tcp        0      0 *:smtp                      *:*                         LISTEN      3914/master
    tcp        0      0 ccs02.correaconsulting:rndc *:*                         LISTEN      2386/named
    tcp        0      0 smtp.correaconsulting:mysql correaconsulting.com:1161   ESTABLISHED 1813/mysqld
    tcp        0      0 *:http                      *:*                         LISTEN      2288/httpd
    tcp        0      0 *:ssh                       *:*                         LISTEN      1715/sshd
    tcp        0      0 *:https                     *:*                         LISTEN      2288/httpd
    tcp        0   2816 ccs02.sthenrygresham.or:ssh ::ffff:72.11.127.232:1324   ESTABLISHED 18078/sshd: postmas
    
    Do I stop xinetd and start dovecot or what?

    Jorge
     
  8. Jcorrea920

    Jcorrea920 New Member

    I tested the Mail server for incoming mail with ipop3d off...

    This is what happens when I try to send mail to accounts on ISPConfig it bounces back on one account and gives me this error:
    Code:
    This is the Postfix program at host ccs02.correaconsulting.com.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to <postmaster>
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
    			The Postfix program
    
    <web3_jorge@correaconsulting.com> (expanded from 
    <jorge@correaconsulting.com>):
        can't create user output file
    
    Message/delivery-status
    
    Reporting-MTA: dns; ccs02.correaconsulting.com
    X-Postfix-Queue-ID: 66AC0C602B4
    X-Postfix-Sender: rfc822; jcorrea920@yahoo.com
    Arrival-Date: Sat,  4 Mar 2006 12:32:16 -0800 (PST)
    
    Final-Recipient: rfc822; web3_jorge@correaconsulting.com
    Original-Recipient: rfc822; jorge@correaconsulting.com
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; can't create user output file
    
    
    Should I just replace xinetd with dovecot or what? Maybe there is something wrong with just this user account? Now the webmail doesn't allow any users to connect on port 110:
    Code:
    Warning: fsockopen() [function.fsockopen]: unable to connect to localhost:110 (Connection refused) in /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau_mail.php on line 66
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau_mail.php:66) in /home/admispconfig/ispconfig/web/webmail/msglist.php on line 64
    
    I seen like I am digging a deeper grave everytime I change something. I don't want to stop xinetd and start dovecot if it will break the system. So please let me know what I can do now. Thank you.:confused:
     
  9. Jcorrea920

    Jcorrea920 New Member

    Solved Issue...

    Falko,
    Thank you for your advice once more. I must say that once I stopped xinetd and started dovecot, I had successful access to my webmail. And the mail server was working fine for everyone else. So then I realized that for my username the webspace was only 50MB which is fine for all other accounts, but since I am the administrator the website takes up quite a bit of space exceeding the limit.

    Solution: all I did was login to ISPConfig as administrator or reseller or even client of the webspace, select users/emails tab. Select my user account and change the 50MB webspace limit/quota to -1. Thank you Falko, love your program, and I will upgrade to the new version if possible this year..:D
     
  10. falko

    falko Super Moderator

    There is an POP3/IMAP file in /etc/xinet.d which you have to edit. Put
    Code:
    disable = yes
    into it and restart xinetd. This way you can run xinetd and dovecot at the same time.
    The chkconfig commands you tried affect only the boot behaviour, it doesn't stop running POP3/IMAP processes. That's why you got those Address already in use errors.
     
  11. abhandari

    abhandari New Member

    Dovecot IPv4 only imap 143 failed

    Boss,

    This is based on CentOS5.4 + dovecot dovecot-1.2.11-3.0.cf.rhel5

    I have the same error. But nothing figured out correctly. I have actually disabled the IPV6 from /etc/modprobe.conf
    ---------------
    alias ipv6 off
    alias net-pf-10 off
    ---------------

    and

    # touch /etc/modprobe.d/disable-ipv6
    # echo "install ipv6 /bin/true" >> /etc/modprobe.d/disable-ipv6
    ------------------

    #chkconfig ip6tables off
    -----------------
    =============
    then. In that situation i have normally configured the dovecot and tryed to restart the dovecot service and have the error: like urz.:-
    ===============================
    [root@smail certs]# service dovecot start
    Starting Dovecot Imap: If you have trouble with authentication failures,
    enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
    This message goes away after the first successful login.
    Fatal: listen:):, 143) failed: Address already in use
    [FAILED]
    [root@smail certs]# service dovecot start
    Starting Dovecot Imap: Fatal: listen:):, 143) failed: Address already in use
    [FAILED]
    [root@smail certs]# service dovecot start
    Starting Dovecot Imap: Fatal: listen:):, 143) failed: Address already in use
    [FAILED]
    [root@smail certs]# service dovecot start
    Starting Dovecot Imap: Fatal: listen:):, 143) failed: Address already in use
    [FAILED]

    ================================

    Amazing u have the solution after some hit and trial:

    Change the line below from /etc/dovecot.conf

    which only listens to your IPV4 addresses for your pop/s imap/s
    =========
    #listen = *, [::]
    to
    listen = *
    =========

    Now restart ur dovecot ---perfectly works man
    =========
    [root@smail ~]# service dovecot restart
    Stopping Dovecot Imap: [FAILED]
    Starting Dovecot Imap: [ OK ]
    -================
     
  12. abhandari

    abhandari New Member

    http://www.howtoforge.com/forums/showthread.php?p=224028#post224028

    Amazing u have the solution after some hit and trial:

    Change the line below from /etc/dovecot.conf

    which only listens to your IPV4 addresses for your pop/s imap/s
    =========
    #listen = *, [::]
    to
    listen = *
    =========

    Now restart ur dovecot ---perfectly works man
    =========
    [root@smail ~]# service dovecot restart
    Stopping Dovecot Imap: [FAILED]
    Starting Dovecot Imap: [ OK ]
    -================
     

Share This Page