Not receiveing mails

Discussion in 'Installation/Configuration' started by ivan_mx, Apr 17, 2008.

  1. ivan_mx

    ivan_mx New Member

    Hi, many thanks for the tuts on the site, i've followed the perfect isp server for ubunto 7.10, im running the 64 bit version of ubuntu server 7.10, i can send emails from the only account i created but can't receive any, i dont know what i'm doing wrong i`ve been reading the hole day the forums but still not get a clue, i will post all that i know so far its important to know ;)

    1.- OS: UBUNTU 7.10 SERVER AMD64
    2.- DOMAIN REGISTERED IN GODADDY: bmbmarketing.com
    3.- Fixed Ip: 200.155.77.228
    4.- ROUTER 2WIRE 2701
    5.- THE DNS CONFIG INSIDE GODADDY:
    Code:
    ; Use at your own risk.
    
    ; A Records
    @	3600	IN	A	201.155.77.228
    
    ; CNAME Records
    server1	3600	IN	CNAME	@
    www	3600	IN	CNAME	@
    ftp	3600	IN	CNAME	@
    
    ; MX Records
    @	3600	IN	MX	10	200.155.77.228
    @	3600	IN	MX	10	server1.bmbmarketing.com
    
    mail.err

    Code:
    Apr 16 20:39:09 server1 postfix/smtpd[6400]: connect from outbound-mail-160.bluehost.com[67.222.39.40]
    Apr 16 20:39:10 server1 postfix/smtpd[6400]: NOQUEUE: reject: RCPT from outbound-mail-160.bluehost.com[67.222.39.40]: 554 5.7.1 <[email protected]>: Relay access denied$
    Apr 16 20:39:10 server1 postfix/smtpd[6400]: disconnect from outbound-mail-160.bluehost.com[67.222.39.40]
    Apr 16 20:39:12 server1 courierpop3login: Connection, ip=[::ffff:201.155.77.228]
    Apr 16 20:39:12 server1 courierpop3login: LOGIN, user=web1_ivan, ip=[::ffff:201.155.77.228]
    Apr 16 20:39:12 server1 courierpop3login: LOGOUT, user=web1_ivan, ip=[::ffff:201.155.77.228], top=0, retr=0, rcvd=12, sent=39, time=0
    Apr 16 20:42:30 server1 postfix/anvil[6442]: statistics: max connection rate 1/60s for (smtp:67.222.39.40) at Apr 16 20:39:09
    Apr 16 20:42:30 server1 postfix/anvil[6442]: statistics: max connection count 1 for (smtp:67.222.39.40) at Apr 16 20:39:09
    Apr 16 20:42:30 server1 postfix/anvil[6442]: statistics: max cache size 1 at Apr 16 20:39:09
    Apr 16 20:44:12 server1 courierpop3login: Connection, ip=[::ffff:201.155.77.228]
    Apr 16 20:44:12 server1 courierpop3login: LOGIN, user=web1_ivan, ip=[::ffff:201.155.77.228]
    Apr 16 20:44:13 server1 courierpop3login: LOGOUT, user=web1_ivan, ip=[::ffff:201.155.77.228], top=0, retr=0, rcvd=12, sent=39, time=0
    
    mail.warn (dont know if its important)

    Code:
    Apr 16 17:39:42 server1 postfix/smtp[13327]: warning: host server1.bmbmarketing.com[201.155.77.228]:25 greeted me with my own hostname server1.bmbmarketing.com
    Apr 16 17:39:42 server1 postfix/smtp[13327]: warning: host server1.bmbmarketing.com[201.155.77.228]:25 replied to HELO/EHLO with my own hostname server1.bmbmarketing.com
    Apr 16 17:39:42 server1 postfix/smtp[13335]: warning: numeric domain name in resource data of MX record for bmbmarketing.com: 200.155.77.228
    Apr 16 17:39:43 server1 postfix/smtpd[13340]: warning: 201.155.77.228: hostname dsl-201-155-77-228.prod-empresarial.com.mx verification failed: Name or service not known
    Apr 16 17:39:43 server1 postfix/smtp[13335]: warning: host server1.bmbmarketing.com[201.155.77.228]:25 greeted me with my own hostname server1.bmbmarketing.com
    Apr 16 17:39:43 server1 postfix/smtp[13335]: warning: host server1.bmbmarketing.com[201.155.77.228]:25 replied to HELO/EHLO with my own hostname server1.bmbmarketing.com
    
    Ive read that you need to send and email to the user first in order to create the necesary folder for it to work but how do i achieve that?, as you can see my english is not in good shape so please dont be mad while reading this post ;)

    Thanks in advance
     
  2. webwork

    webwork New Member

    You don't need the IP only MX

    If it is going to work at all it won't need the IP only MX. If the mail software is set to recognize the mail at the host setting the IP may not work properly. Both MX records have the same priority so it might default to the IP first. Also, Check the host and domain setting in the network external adapter ip settings and also the mail settings. If you want to pick up the mail at the IP sometimes you need to show the IP as follows: [email protected]
    With server settings as: [199.201.222.1] as the host
     
  3. ivan_mx

    ivan_mx New Member

    done but no luck

    i removed the ip from the mx records but still not working : (
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Code:
    server2:~# dig mx bmbmarketing.com
    
    ; <<>> DiG 9.3.4 <<>> mx bmbmarketing.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11278
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;bmbmarketing.com.              IN      MX
    
    ;; ANSWER SECTION:
    bmbmarketing.com.       3600    IN      MX      10 [B][COLOR="Red"]server1.bmbmarketing.com[/COLOR][/B].
    
    ;; Query time: 326 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Thu Apr 17 22:30:31 2008
    ;; MSG SIZE  rcvd: 58
    
    server2:~# dig server1.bmbmarketing.com
    
    ; <<>> DiG 9.3.4 <<>> server1.bmbmarketing.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21262
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server1.bmbmarketing.com.      IN      A
    
    ;; ANSWER SECTION:
    [B][COLOR="Red"]server1.bmbmarketing.com. 3594  IN      CNAME   bmbmarketing.com.[/COLOR][/B]
    bmbmarketing.com.       3594    IN      A       201.155.77.228
    
    ;; Query time: 36 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Thu Apr 17 22:30:37 2008
    ;; MSG SIZE  rcvd: 72
    
    server2:~#
    The problem is that the MX record is pointing to a CNAME record. It must point to an A record.
     
  5. ivan_mx

    ivan_mx New Member

    how to?

    Thansk falko but is this dns record on my server or in godaddy? cus i cant find it the server
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Code:
    server2:~# dig ns bmbmarketing.com
    
    ; <<>> DiG 9.3.4 <<>> ns bmbmarketing.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58520
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;bmbmarketing.com.              IN      NS
    
    ;; ANSWER SECTION:
    bmbmarketing.com.       172800  IN      NS      [B][COLOR="Red"]ns17.domaincontrol.com[/COLOR][/B].
    bmbmarketing.com.       172800  IN      NS      [B][COLOR="Red"]ns18.domaincontrol.com[/COLOR][/B].
    
    ;; ADDITIONAL SECTION:
    ns18.domaincontrol.com. 172800  IN      A       208.109.255.9
    ns17.domaincontrol.com. 172800  IN      A       64.202.165.120
    
    ;; Query time: 149 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Thu Apr 17 23:05:51 2008
    ;; MSG SIZE  rcvd: 118
    
    server2:~#
    That seem to be GoDaddy servers.
     

Share This Page