Not possible to update to 2.2.34 on Ubuntu 9.10

Discussion in 'Installation/Configuration' started by benburner, Nov 4, 2009.

  1. benburner

    benburner New Member

    Hey there,

    I just tried to update to ISPConfig 2.2.34 (from 2.2.33) on Ubuntu 9.10 but it fails (any updates before worked flawlessly).

    The first try gave that result:

    Also, when I tried to restart Apache 2, it couldn't because of this line in the apache2.conf:

    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
    I know, I shouldn't comment it out as it breaks logging, but ISPConfig isn't currently working anymore, so I didn't "care".

    uname -a is
    2.6.28-16-server #55-Ubuntu SMP Tue Oct 20 20:37:10 UTC 2009 x86_64 GNU/Linux
    If you need any more details, please let me know!

    Thanks in advance for any help.

    - Ben
    Last edited: Nov 5, 2009
  2. benburner

    benburner New Member

    Point 16 of helped me to be able to compile ISPConfig.

    Now, it's

    [Thu Nov  5 14:40:05 2009] [error] mod_ssl: Init: Unable to read server certificate from file /root/ispconfig/httpd/conf/ssl.crt/server.crt (OpenSSL library error follows)
    [Thu Nov  5 14:40:05 2009] [error] OpenSSL: error:0D06B08E:asn1 encoding routines:ASN1_D2I_READ_BIO:not enough data
    In …/ispconfig/httpd/logs/error.log

    I guess I will be able to solve that, too. Will post the result here as Google food for everyone else with the same problem.
    Last edited: Nov 5, 2009
  3. falko

    falko Super Moderator ISPConfig Developer

    Before you install ISPConfig, there's one important thing you must do. Open /usr/include/stdio.h and replace getline with parseline in line 651:

    vi /usr/include/stdio.h
       This function is not part of POSIX and therefore no official
       cancellation point.  But due to similarity with an POSIX interface
       or due to the implementation it is a cancellation point and
       therefore not marked with __THROW.  */
    extern _IO_ssize_t parseline (char **__restrict __lineptr,
                                size_t *__restrict __n,
                                FILE *__restrict __stream) __wur;
    If you don't do this, the installation will fail because of the following error:

    htpasswd.c:101: error: conflicting types for 'getline'
    /usr/include/stdio.h:651: note: previous declaration of 'getline' was here
    make[2]: *** [htpasswd.o] Error 1
    make[2]: Leaving directory `/home/ISPConfig-2.2.stable/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    make[1]: *** [build-support] Error 1
    make[1]: Leaving directory `/home/ISPConfig-2.2.stable/install_ispconfig/compile_aps/apache_1.3.41'
    make: *** [build] Error 2
    ERROR: Could not make Apache
  4. benburner

    benburner New Member

  5. benburner

    benburner New Member

    Yep, that did the trick. Thank you very much!

    (I wonder why it worked before all the times? Never had to do that before. Anyway, solved, and I'm a happy panda!)

Share This Page