Not crating mailboxes

Discussion in 'Installation/Configuration' started by spacepills, Feb 6, 2014.

  1. spacepills

    spacepills Member

    When creating a new mailbox in ISPConfig, it creates the directories to an extent.
    /var/vmail/ is created and it creates some folders inside this:
    • courierimapkeywords
    • courierimapsubscribed
    • courierimapuiddb
    • cur
    • new
    • subscriptions
    • tmp
    it does not create any inbox or anything like that.
    I get "ERROR: Could not complete request.
    Query: SELECT "INBOX"
    Reason Given: Unable to open this mailbox." from Squirrelmail
    when sending emails to an account on my server I get
    "status=deferred (mail transport unavailable)" and
    "warning: connect to transport private/courier-imap: No such file or directory"
    when connecting via telnet :143 I get
    a NO Unable to open this mailbox.
    and if I connect over :110 I get
    -ERR Maildir invalid (no 'cur' directory)

    Essentially I don't think the Maildir is being created correctly but I can't for the life of me figure out why and spent far too long on it, going through forums which have got me so far but there's not anything I can find that has the same problem(s) as me, or the same cause.

  2. spacepills

    spacepills Member

    Ok solved most of it, my idiocy and not changing a setting in ISPconfig,

    Server Config, Mail, POP3/IMAP Daemon was set to Dovecot and I'm using courier.

    So most of those issues are now all gone.

    The only one that still remains is receiving emails, I get
    "status=deferred (mail transport unavailable)" still.
    I think there is a problem in my postfix file but I don't want to make it worse!
  3. spacepills

    spacepills Member

    myhostname =
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    myorigin = /etc/mailname
    mydestination = localhost, localhost.localdomain
    relayhost =
    mynetworks = [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/, proxy:mysql:/etc/postfix/, hash:/var/lib/mailman/data/virtual-mailman
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    inet_protocols = all
    smtpd_sasl_auth_enable = no
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/, reject_unauth_destination
    smtpd_tls_security_level = may
    transport_maps = hash:/var/lib/mailman/data/transport-mailman, proxy:mysql:/etc/postfix/
    relay_domains = mysql:/etc/postfix/
    relay_recipient_maps = mysql:/etc/postfix/
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_cano$
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/
    smtpd_client_message_rate_limit = 100
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = courier-imap
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    owner_request_special = no
    dovecot_destination_recipient_limit = 1
    smtpd_sasl_type = courier-imap
    smtpd_sasl_path = private/auth
    content_filter = amavis:[]:10024
    receive_override_options = no_address_mappings
    queue_directory = /var/spool/postfix
    message_size_limit = 0
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Which tutorial did you follow to install your server? Did you change imap daemon from dovecot to courier after you installed ispconfig?
  5. spacepills

    spacepills Member

    Yeah, I messed up somewhere, nothing was working so I gave it a shot, I used the perfect server for Ubuntu 13.04. Everything is working, folders working, sending mail is working, tailing the mail.log and sending an email from hotmail I get this (emails etc changed)

    Feb 6 11:15:37 vps2 postfix/smtpd[29451]: connect from[]
    Feb 6 11:15:37 vps2 postfix/smtpd[29451]: A74EB161713:[]
    Feb 6 11:15:37 vps2 postfix/cleanup[29453]: A74EB161713: message-id=<[email protected]>
    Feb 6 11:15:37 vps2 postfix/qmgr[28295]: A74EB161713: from=<[email protected]>, size=1456, nrcpt=1 (queue active)
    Feb 6 11:15:37 vps2 postfix/smtpd[29451]: disconnect from[]
    Feb 6 11:15:39 vps2 postfix/smtpd[29616]: connect from localhost[]
    Feb 6 11:15:39 vps2 postfix/smtpd[29616]: 5F734161716: client=localhost[]
    Feb 6 11:15:39 vps2 postfix/cleanup[29453]: 5F734161716: message-id=<[email protected]>
    Feb 6 11:15:39 vps2 postfix/qmgr[28295]: 5F734161716: from=<[email protected]>, size=1901, nrcpt=1 (queue active)
    Feb 6 11:15:39 vps2 postfix/qmgr[28295]: warning: connect to transport private/courier-imap: No such file or directory
    Feb 6 11:15:39 vps2 postfix/smtpd[29616]: disconnect from localhost[]
    Feb 6 11:15:39 vps2 postfix/error[29465]: 5F734161716: to=<[email protected]>, relay=none, delay=0.02, delays=0.01/0.01/0/0.01, dsn=4.3.0, status=deferred (mail transport unavailable)
    Feb 6 11:15:39 vps2 amavis[28742]: (28742-02) Passed CLEAN {RelayedInbound}, []:48764 [] <[email protected]> -> <[email protected]>, Queue-ID: A74EB161713, Message-ID: <[email protected]>, mail_id: wuQQ38VGEGNW, Hits: 0.101, size: 1457, queued_as: 5F734161716, 1684 ms
    Feb 6 11:15:39 vps2 postfix/smtp[29454]: A74EB161713: to=<[email protected]>, relay=[]:10024, delay=1.8, delays=0.07/0/0/1.7, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[]:10025): 250 2.0.0 Ok: queued as 5F734161716)
    Feb 6 11:15:39 vps2 postfix/qmgr[28295]: A74EB161713: removed

    any ideas?
  6. spacepills

    spacepills Member

    Fixed it I think.

    Changed a few things in and then was getting "virtual_mailbox_limit is smaller than message_size_limit", realised there was no line for virtual_mailbox_limit, put it in, set it higher than message_size_limit and I get hundreds of test emails coming through!
  7. spacepills

    spacepills Member


    Set both to 0 for no limit and works fine.

Share This Page