Not able to send mails (unless to myself)

Discussion in 'Installation/Configuration' started by pduersteler, Sep 1, 2011.

  1. pduersteler

    pduersteler New Member

    I'm facing a strange problem and I am in hope someone can give me a hint on this.

    ISPConfig 3.0.3.3 on Debian. Everything but mailing seems to work. I've set up domains, mailboxes etc and set up a mail client to senc/receive over imap.

    When I try to send a mail from an accoutn configured in ispconfig to itself, it works. But when I want to send a mail to my private gmail address I don't receive anything there. Sending from gmail to my ispconfig defined mailbox works, though.

    I don't get any log entries in mail.log, mail.err, mail.warn, mail.info or my custom dovecot debug log when sending a mail.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you dont get any lines in the mail.log file, then the email is not send trough your server. Please double check that the smpt server setting in your email client is the IP address or hostname of your server. Then try to send again, you must see that lines get added in the /var/log/mail.log file then.
     
  3. pduersteler

    pduersteler New Member

    Thanks for your reply!

    I got log entries when sending from myself to myself. Now I tested a few things with telnet and found out that the problem has to be the firewall. As you said, the mail doesn't even reach the server. That's because the firewall forwards to another smtp gate which, obviously, doesn't know the accounts I want to send from.
     

Share This Page