Not able to login to myphpadmin

Discussion in 'ISPConfig 3 Priority Support' started by Paul Hill, Sep 29, 2017.

  1. Paul Hill

    Paul Hill New Member HowtoForge Supporter

    HI Guys
    I'm not particularly familiar with Linux , I usually blunder my way through things when I need to with the help of google ..
    Got a client that needs to run a DB on our isp server , we use (Ubuntu 16.04.1 LTS (Xenial Xerus)) ISPConfig 3.1.2
    If I try to access it (serverip)/myphpadmin I get the following :-
    The requested URL /myphpadmin was not found on this server.

    Can you offer words of wisdom on this please ?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The url (and name of the software) is '/phpmyadmin' and not '/myphpadmin'.
     
  3. Paul Hill

    Paul Hill New Member HowtoForge Supporter

    sorry that was a typo
    this is what I type
    http://192.168.1.85/phpmyadmin

    this is what I get

    Not Found
    The requested URL /phpmyadmin was not found on this server.

    Apache/2.4.18 (Ubuntu) Server at 192.168.1.85 Port 80
     
  4. HSorgYves

    HSorgYves Active Member

    What is the output of:
    Code:
    ls -la /etc/apache2/conf*/
     
  5. Paul Hill

    Paul Hill New Member HowtoForge Supporter

    /etc/apache2/conf-available/:
    total 48
    drwxr-xr-x 2 root root 4096 Sep 19 14:58 .
    drwxr-xr-x 8 root root 4096 Sep 19 14:58 ..
    -rw-r--r-- 1 root root 221 Mar 19 2016 apache2-doc.conf
    -rw-r--r-- 1 root root 315 Mar 19 2016 charset.conf
    -rw-r--r-- 1 root root 73 Feb 8 2017 httpoxy.conf
    -rw-r--r-- 1 root root 127 Aug 11 2013 javascript-common.conf
    -rw-r--r-- 1 root root 3224 Mar 19 2016 localized-error-pages.conf
    lrwxrwxrwx 1 root root 24 Feb 8 2017 mailman.conf -> /etc/mailman/apache.conf
    -rw-r--r-- 1 root root 189 Mar 19 2016 other-vhosts-access-log.conf
    -rw-r--r-- 1 root root 1316 Dec 1 2016 php7.0-cgi.conf
    -rw-r--r-- 1 root root 728 Dec 1 2016 php7.0-fpm.conf
    lrwxrwxrwx 1 root root 26 Feb 8 2017 roundcube.conf -> /etc/roundcube/apache.conf
    -rw-r--r-- 1 root root 2174 Mar 19 2016 security.conf
    -rw-r--r-- 1 root root 455 Mar 19 2016 serve-cgi-bin.conf
    /etc/apache2/conf-enabled/:
    total 8
    drwxr-xr-x 2 root root 4096 Feb 16 2017 .
    drwxr-xr-x 8 root root 4096 Sep 19 14:58 ..
    lrwxrwxrwx 1 root root 34 Feb 8 2017 apache2-doc.conf -> ../conf-available/apache2-doc.conf
    lrwxrwxrwx 1 root root 30 Feb 8 2017 charset.conf -> ../conf-available/charset.conf
    lrwxrwxrwx 1 root root 30 Feb 8 2017 httpoxy.conf -> ../conf-available/httpoxy.conf
    lrwxrwxrwx 1 root root 44 Feb 8 2017 localized-error-pages.conf -> ../conf-available/localized-error-pages.conf
    lrwxrwxrwx 1 root root 46 Feb 8 2017 other-vhosts-access-log.conf -> ../conf-available/other-vhosts-access-log.conf
    lrwxrwxrwx 1 root root 32 Feb 8 2017 roundcube.conf -> ../conf-available/roundcube.conf
    lrwxrwxrwx 1 root root 31 Feb 8 2017 security.conf -> ../conf-available/security.conf
    lrwxrwxrwx 1 root root 36 Feb 8 2017 serve-cgi-bin.conf -> ../conf-available/serve-cgi-bin.conf
    [email protected]:~#
     
  6. HSorgYves

    HSorgYves Active Member

    You don't have an active phpmyadmin configuration loaded into apache.
    What's the result of:
    Code:
    ls -la /etc/phpmyadmin/
     
  7. Paul Hill

    Paul Hill New Member HowtoForge Supporter

    total 60
    drwxr-xr-x 3 root root 4096 Feb 8 2017 .
    drwxr-xr-x 122 root root 12288 Sep 19 14:58 ..
    -rw-r--r-- 1 root root 1448 Mar 30 2016 apache.conf
    drwxr-xr-x 2 root root 4096 Jun 17 2016 conf.d
    -rw-r----- 1 root www-data 522 Feb 8 2017 config-db.php
    -rw-r--r-- 1 root root 168 Oct 29 2015 config.footer.inc.php
    -rw-r--r-- 1 root root 168 Oct 29 2015 config.header.inc.php
    -rw-r--r-- 1 root root 6319 Jan 30 2016 config.inc.php
    -rw-r----- 1 root www-data 8 Feb 8 2017 htpasswd.setup
    -rw-r--r-- 1 root root 570 Oct 29 2015 lighttpd.conf
    -rw-r--r-- 1 root root 198 Oct 29 2015 phpmyadmin.desktop
    -rw-r--r-- 1 root root 295 Oct 29 2015 phpmyadmin.service
     
  8. HSorgYves

    HSorgYves Active Member

    OK, enable phpmyadmin using:
    Code:
    cd /etc/apache2/conf-enabled/
    ln -s ../../phpmyadmin/apache.conf phpmyadmin.conf
    service apache2 reload
    If reload of apache is enough, you need to restart it.
     
  9. Paul Hill

    Paul Hill New Member HowtoForge Supporter

    Perfect , works now , that is a permanent change now right ? if the server is rebooted it will still work ?
    Sorry for my ignorance :(
    Thankyou
     
  10. HSorgYves

    HSorgYves Active Member

    Yes, it is a permanent change and will stay even if you reboot.
     
  11. Paul Hill

    Paul Hill New Member HowtoForge Supporter

    So next step , client installed their website and created their database but are getting this permission issues ...

    FORBIDDEN
    you don't have permission to access / on this server.
    Addditionally , a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    What is my next course of action ?
    It is a word press site
    Thanks
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    How did you try to access the website, by it's domain name?
     
  13. Paul Hill

    Paul Hill New Member HowtoForge Supporter

    Yes by going to the website in a browser
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, Then you probably have no PHP enabled. check the website settings and ensure that php mode is set to php-fcgi or php-fpm
     
  15. Paul Hill

    Paul Hill New Member HowtoForge Supporter

    perfect , thanks Till
     

Share This Page