not able to delete/clean the tmp folder.

Discussion in 'ISPConfig 3 Priority Support' started by pawan, May 13, 2021.

  1. pawan

    pawan Member HowtoForge Supporter

    for a specific vhost, which has Magento2 instance installed.
    I can see that the size of tmp folder is 1GB+
    web folder is 34G
    home 1.7G
    yet in ispconfig panel total space used is showing as 154Gb.
    The backup is stored as root user and it is on a separate hdd.
    another problem is whatever I try I am not able to delete the contents of tmp folder.
    I have tried everything including
    rm -rf tmp
    rm tmp/*
    rm -rf tmp/*
    lsattr command returns
    --------------e--- ./webdav
    --------------e--- ./log
    --------------e--- ./ssl
    --------------e--- ./web
    --------------e--- ./backup
    --------------e--- ./cgi-bin
    --------------e--- ./private
    -----------I--e--- ./tmp
    --------------e--- ./home
    so I tried with
    chattr -i tmp
    but nothing seems to help.
    so basically 2 issues.
    1. used space issue.
    2. not able to delete files.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    What does repquota show for the web user? You can find files owned by the user with eg. 'find / -type f -user web123'.
    What are the files' owner and permissions?
     
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Is "Include backup files into web quota." enabled under System -> Main config -> Sites?
     
  4. pawan

    pawan Member HowtoForge Supporter

    no - checkbox is not checked.
     
  5. pawan

    pawan Member HowtoForge Supporter

    for the tmp where I am not able to delete - permissions show like this:
    drwxrwx--- 2 web1 client1 1013M May 14 00:29 tmp
     
  6. pawan

    pawan Member HowtoForge Supporter

    when I am trying - rm -rf tmp/*
    I am getting
    -bash: /bin/rm: Argument list too long
    but when I try cd tmp and
    find . -name "*.*" -delete
    the command executes, but the folder size still shows 1013M
     
  7. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    There are probably (many?) files without a period in their name, maybe try '-type f' rather than '-name "*.*"'
     

Share This Page