noobie email questions with ispconfig and debian 4 etch

Discussion in 'Installation/Configuration' started by biobrew, Jun 28, 2008.

  1. biobrew

    biobrew New Member

    I'm having all sorts of email problems. I can't seem to send email to anyone, not from inside the network or outside the network, except I can send mail from inside the network to myself ([email protected]).

    I can telnet to port 25
    and then
    ehlo localhost
    and I get the proper output.

    The username I'm using is web1_mark with the email address of [email protected]

    When I'm on the box and type:

    sendmail -v [email protected]
    test
    ctrl + d

    I get the output sent to root which I can check in /var/mail/nobody (which is kind of weird that the root mail is going to nobody)

    The output is this:

    Code:
    <[email protected]> (expanded from <[email protected]>): delivery
        via local: forwarded as 9D403180C54C
    
    --99527180C54E.1214609960/server1.safetytg.com
    Content-Description: Delivery report
    Content-Type: message/delivery-status
    
    Reporting-MTA: dns; server1.safetytg.com
    X-Postfix-Queue-ID: 99527180C54E
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Fri, 27 Jun 2008 16:39:18 -0700 (PDT)
    
    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822; [email protected]
    Action: relayed
    Status: 2.0.0
    Diagnostic-Code: X-Postfix; delivery via local: forwarded as 9D403180C54C
    The mail users seem to be:

    Code:
    server1:/var/mail# ls
    admispconfig  nobody  web1_mark  web2_mark
    But after sending mail to [email protected] there is no mail for that user and nothing inside the file web1_mark

    I'll be the first to admit that I'm not exactly sure what I'm doing with setting up email accounts using ispconfig.

    in /var/log/mail.log I'm not getting anything at all after sending mail as root to [email protected]

    That's just internal mail so far. Any suggestions?
     
  2. biobrew

    biobrew New Member

    I'm not sure if this has anything to do with it but I'm getting these messages in my mail logs / warnings / errors:

    Jun 26 02:35:34 server1 freshclam[19806]: Current functionality level = 29, recommended = 31
    Jun 26 04:59:34 server1 freshclam[19806]: Your ClamAV installation is OUTDATED!
    Jun 26 04:59:34 server1 freshclam[19806]: Local version: 0.93 Recommended version: 0.93.1

    How do I update ClamAV to newest version?
     
  3. biobrew

    biobrew New Member

    Just got off the phone with my ISP and they assured me port 25 was open for my account and on my router with a static ip address... oi. So far the email thing as been the most difficult to get working. Nothing I seem to do makes it send mail out to the real world. And I still can't seem to send mail from inside the network. And doing sendmail -v [email protected] sends the report not to root but to /var/mail/nobody

    Anyone know what's going on?
     
  4. biobrew

    biobrew New Member

    Okay so apparently the person I talked to at AT&T was dumber than me.

    AT&T digital line subscribers (dsl customers) can no longer relay through port 25, they have to do it through smtp.att.yahoo.com on port 465 using ssl email.

    So my next question is...

    How can I ensure all emai sent out is over that port and secure so that AT&T will route my email?
     
  5. falko

    falko Super Moderator ISPConfig Developer

  6. biobrew

    biobrew New Member

    Awesome. Still not working 100% but now I'm getting very specific authentication errors which is definitely a step in the right direction.

    I don't really have a deadline on this so I haven't been on it like I should but when I get it working I'll post my entire main.cf file from and anything else I changed to make it work with port 587 and TLS.. :)
     
  7. biobrew

    biobrew New Member

    Okay I'm able to send out emails now using TLS and using something along the lines of:

    sendmail -f "my_real_at&[email protected]" [email protected]

    But... I still can't seem to send mail from [email protected]

    How can I make it so that I send emails from the right domain without having to send it from my username? This is kind of AT&T specific I guess, but before I started sending out emails with that "from" address, I was getting error 553 relaying denied from AT&T servers.

    Is there a way to fudge the servers where I can send out a from address that doesn't get denied that's from my own domain?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. biobrew

    biobrew New Member

    I have it set up like that to a tee which is why I'm able to send out emails now, but I have to set the "from" option to my actual email from att.net that I get for having them as my ISP.

    If I change the from option to anything else I get a 553 relay denied message.

    so this works:

    sendmail -f "[email protected]" [email protected]

    and this does not:(

    sendmail -f "any_ol_made_up_email@any_ol_domain.com" [email protected]

    AT&T's smtp authentication mechanism seems to be making me send a verified "From" with any relayed mail, regardless of having my username and password sent with the email using postfix's sasl_passwd method.

    Am I just doing something really retarded? Shouldn't I be able to relay from any name/email address once I authenticate with them using the sasl_passwd method?
     
  10. biobrew

    biobrew New Member

    Okay phew WOW this has been a learning adventure.

    If you have AT&T and are having trouble relaying than this thread is for you:

    So I've been on and off the phone with my ISP AT&T for days now at this...

    I got this email not too long ago from them, this is the email verbatim:


    If you visit the site that they link to in the email, it gives detailed instructions on how to set up a "verified" mail account by hand, one at a time, for each email address you would like to relay through their servers.

    That part sucks. The fact that if I want to host websites at my house through my crappy DSL service, then every single email address I also want to host must be "verfieid" (they send you a verification code to the email address you register with them and you have to re-type it in their prompt).

    So there it is, ISPConfig has worked great from the start, in fact, doing everything this site has told me has worked absolutely perfectly each time. The entire time emails were wonky because AT&T are absolute spam nazis.

    I'd just like to give a big thanks to the guys here who write the tutorials and who answer these posts. you guys rule. You have completely renewed my interest in Linux. /sap
     

Share This Page