Noob with ?'s

Discussion in 'General' started by MattJo., May 11, 2010.

  1. MattJo.

    MattJo. New Member

    Hi All,

    I am 4 days new to Ubuntu and I have installed Falko's Perfect Server with ISPConfig 3. I also installed the desktop. I have a ton of questions and am not sure where to begin. I am pretty much ignorant in CLI-world, but am a fast learner.

    So, everything up to the end of the Perfect Server instructions works. I set /etc/network/interfaces for my two ethernet ports thus (I totally guessed at this):
    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 192.168.x.xxx
    netmask 255.255.255.0
    network 192.168.x.x
    broadcast 192.168.x.255
    gateway 192.168.x.1

    auto eth1
    iface eth1 inet static
    address xxx.xxx.xx.97
    netmask 255.255.255.xxx
    gateway xxx.xxx.xx.102

    Ultimately I set the a-record (and mx records) with the domain seller and was able to "see" the server at all local and public ip's and domain name. However, during initial setup I forgot to change the "dhcp" to "static" in the file and was confused as to why I wasn't able to ssh to the server on the ip address. So I tried setting it via the desktop and was able to ssh. I later discovered my mistake and amended dhcp to static. The weird thing is I went back and deleted the ip settings in the desktop network connections and the server still has the same local ip and I can see locally, but Firefox in the desktop won't connect to any webpages and I can't access it remotely either via ip or domain name.

    Is this because i haven't set up DNS on the server?

    I have more questions, but more later.

    thanks in advance for any help.
     
  2. falko

    falko Super Moderator

    Is your desktop on the same machine, or is it a different system?
    Can you post the output of
    Code:
    ifconfig
    on the server?
    Do connections from outside your LAN work?
     
  3. MattJo.

    MattJo. New Member

    Falko,

    Thanks. The desktop is on the same machine. Connections to the outside work as long as I keep the GUI "network connections" settings set with the same info entered for eth0. If I delete them, but ensure that the settings are "set" in the /etc/network/interfaces
    I cannot connect to the outside and vice versa I cannot connect to the domain or via the WAN ip. I've even pulled them up in vim-nox to check that the settings didn't change.

    My gut tells me this is a DNS issue, but I don't know. I haven't gotten that far yet ;-)

    thanks again,

    Matt


    eth0 Link encap:Ethernet HWaddr xx:x1:x1:xx:x1:xx
    inet addr:192.168.x.xxx Bcast:192.168.x.255 Mask:255.255.255.0
    inet6 addr: xx11::xxx:11xx:xxxx:111x/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:149092 errors:0 dropped:0 overruns:0 frame:0
    TX packets:34852 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:18746063 (18.7 MB) TX bytes:16474189 (16.4 MB)
    Memory:dc100000-dc120000

    eth1 Link encap:Ethernet HWaddr 11:91:67:xb:51:2s
    inet addr:xxx.xxx.xx.97 Bcast:xxx.xxx.xx.103 Mask:255.255.255.xxx
    inet6 addr: xx11::111:11xx:xxxx:111x/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:13485 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8471 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:2427254 (2.4 MB) TX bytes:1162732 (1.1 MB)
    Memory:dc200000-dc220000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:29453 errors:0 dropped:0 overruns:0 frame:0
    TX packets:29453 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2373390 (2.3 MB) TX bytes:2373390 (2.3 MB)
     
  4. falko

    falko Super Moderator

    I guess the problem is that the desktop comes with a network manager that overrides /etc/network/interfaces. Try to disable the network manager.
     
  5. MattJo.

    MattJo. New Member

    It worked (with some fussing)

    Falko,

    Since I am new I had to find the commands to remove the network manager, but ultimately I ran:

    ? sudo aptitude remove network-manager network-manager-gnome ?

    But this left me without connectivity within the gnome desktop. So, on a hunch, I reinstalled the network manger with this

    ? sudo aptitude install network-manager ?

    At any rate, I have connectivity restored within the desktop and I am able to connect to the server on the public domain/ip.

    thanks very much!

    Matt
     
  6. Sinchan

    Sinchan New Member

    first use manual page for help. Its' always be my guide :
    $ man aptitude
    $ aptitude --help

    For example, if you need to find what exactly packages name for network manager, you can try like this:
    $ aptitude search manager
     

Share This Page