noob samba question

Discussion in 'Server Operation' started by paarono, May 2, 2013.

  1. paarono

    paarono New Member

    Hello, I am building a media server using samba and learning it at the same time. I followed the instructions here ( and am able to access the two account home directories using "smb://###/###/#/##/user" or using command-K (via OSX) to access the same URL.

    So that all works, but in the tutorial it has you "mkdir -p /home/shares/allusers" What is this folder for and how do i access it? I tried variations of the above connection methods and can not seem to access this folder.

    Any further explanation would be much appreciated.

    Thank you!
  2. martin1977

    martin1977 New Member

    It says in the howto that this is a common share folder for all users. The folder is created with mkdir -p /home/shares/allusers and then the appropriate rights are assigned with chown ... and chmod ...
  3. paarono

    paarono New Member

    Hello martin1977, thanks for the reply!

    The original issue i posted was that for what ever reason (perhaps i did not restart the service?) I was not able to see this allusers directory when logging in from OSX. I could access my home folder just fine.

    Now I am able to see the allusers share from OSX but it will not let me access it. I get an error that is telling me

    "the operation can not be completed because the original item for alluers can not be found" Any idea what this means?

    I also decided I wanted to have this share folder on a different partition (a raid5 set up actually) and so i went through this tutorial again thinking that maybe i did something wrong and another go would fix my mistake. Now after changing the location here to a new path -
    comment = All Users
    path = /mnt/raid/share

    i am still seeing the original allusers directory with the same error and the new directory is no where in sight.

    Do i need to configure how OSX works with Samba? I tried accessing the allurers via another linux box i was able to set up also and it seemed to have no issues making this connection to the original share.

  4. martin1977

    martin1977 New Member

    did you copy and paste
    "the operation can not be completed because the original item for alluers can not be found"
    If so, then you hay a typo in "alluers" which should be "allusers"
    Also, after making changes you need to restart the samba service.
  5. paarono

    paarono New Member

    Thanks again martin1977,

    Turns out the typo was OSX auto correct so I was looking for the correct share after all. The problem i had was with permissions, the user I set up as part of the tutorial was not the user i was working with to test the share. I had to add my day to day user to the Users group.

    Thank you for all the kind replies.

Share This Page