Noob question. How to update to ISPConfig 3.0.5.4p6 from ISPConfig 3.0.5.4p5

Discussion in 'General' started by Igor Almeida, May 16, 2015.

  1. Igor Almeida

    Igor Almeida Member

    I just can't find the ispconfig_update.sh file. Can some one point me to the right direction?
    Thank you,
    Igor
     
  2. DDArt

    DDArt Member HowtoForge Supporter

    Normally if you just type:
    Code:
    sudo ispconfig_update.sh
    It should throw up the menu/update procedures.
    Depending on what O/S but should be in the, /usr/local/bin/ispconfig_update.sh.
     
  3. Igor Almeida

    Igor Almeida Member

    thank you!
     
  4. Igor Almeida

    Igor Almeida Member

    Apache fails to start:
    • [Sat May 16 17:45:51.454505 2015] [ssl:warn] [pid 5436] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    • [Sat May 16 17:45:51.454602 2015] [ssl:emerg] [pid 5436] AH02238: Unable to configure RSA server private key
    • [Sat May 16 17:45:51.454628 2015] [ssl:emerg] [pid 5436] SSL Library Error: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
    • [Sat May 16 17:45:51.454654 2015] [ssl:emerg] [pid 5436] AH02312: Fatal error initialising mod_ssl, exiting.
    Any help?
     
  5. DDArt

    DDArt Member HowtoForge Supporter

    Could be few things, it could be caused by the initial CommonName, check your error_log. Your certificate or crt file, check permission, make sure Apache can read it and another one is the ServerName in Apache directive to have it set properly, httpd.con..
    Code:
    #ServerName www.example.com:80
    ServerName www.yourdomain.com
    Could be that your private key and certificate do not match. Did you generate new cert, or might have skipped some questions or the paraphrase?
    When did you get this problem, after upgrade.. etc.

    Check this post here:
    https://www.howtoforge.com/communit...rror-apache-does-not-start.53543/#post-260396
    That might shed some light or help you out.
     
  6. Igor Almeida

    Igor Almeida Member

    I got it working. For some reason the update rewrote the ispconfig vhost.conf. I just had to edit it with the right certificates names.

    Thank you for the reply though.
     

Share This Page