NOMACHINE - NX - Unable to run nxmanager

Discussion in 'Server Operation' started by jcdole, Apr 12, 2011.

  1. jcdole

    jcdole New Member


    Opensuse 11.3

    here is my configuration files :

    /etc/sysconfig/apache2 :

    Note : Doing this way ( recommanded by apache documentation ) I don't know if it is the good way as recommended by NOMACHINE documentation : <<It can be updated by adding the following directive before the "Global Environment" section >>

    Include /usr/NX/etc/manager.conf

    /usr/NX/etc/manager.conf :
    Alias /nxmanager/ "/usr/NX/share/htdocs/nxmanager/"
    ScriptAlias "/nxmanager" "/usr/NX/bin/nxmanager"
    <Directory "/usr/NX/">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all

    /usr/NX/etc/manager.cfg ( just the modify part) :
    # Specify user name of Apache owner.
    #ApacheUname = "nobody"
    ApacheUname = "wwwuser"

    # Specify group name of Apache owner.
    #ApacheGname = "nogroup"
    ApacheGname = "wwwgroup"

    Running this http://localhost/nxmanager from firefox I get :

    The requested operation could not be completed
    Internal Error in Server
    Details of the Request:
    URL: http://localhost/nxmanager
    Protocol: http
    Date and Time: Monday 11 April 2011 22:03
    Additional Information: localhost
    The program on the server which provides access to the http protocol has reported an internal error: localhost.
    Possible Causes:
    This is most likely to be caused by a bug in the server program. Please consider submitting a full bug report as detailed below.
    Possible Solutions:
    Contact the administrator of the server to advise them of the problem.
    If you know who the authors of the server software are, submit the bug report directly to them.

    Running this http://localhost/nxmanager/ from firefox I get this :

    Access forbidden!
    You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.
    If you think this is a server error, please contact the webmaster.
    Error 403

    any help should be great.

    Any way, nxclient is working. I can connect to server from my laptop or locally.

    Additional information :

    [Tue Apr 12 14:05:39 2011] [error] [client] nxmanager: WARNING: configuration file '/usr/NX/etc/manager.cfg' does not exist
    [Tue Apr 12 14:05:39 2011] [error] [client] main: cannot write directory '/usr/NX/var/db/manager': Permission denied
    [Tue Apr 12 14:05:39 2011] [error] [client] Premature end of script headers: nxmanager

    /usr/NX/etc/manager.cfg is owned by nobody:nobody permissions : 640
    /usr/NX/etc/manager.conf is owned by nobody:nobody permissions : 640

    Thank you for your time.

    Last edited: Apr 12, 2011
  2. jcdole

    jcdole New Member


    Partially solved by re-running nxmanager --update.

    But know can't log with success in the nxmanager login screen :
    password error.
    But there no defined password ( and no passwdDB at all ) as I use SSHD authentication with PAM is enabled.

    Both 'EnableUserDB' and 'EnablePasswordDB' are set to 0, so any user are being authenticated by SSHD account and then will be enabled to connect to the system.

    So How to connect to nxmanager ?

Share This Page