No zone files or named.conf entries are being created?

Discussion in 'Installation/Configuration' started by wangster, Mar 1, 2007.

  1. wangster

    wangster New Member

    SUSE 10.2 as per the instructions.

    When we create a "New Master" via the DNS Manager page there are no changes made to the name server's config files and no zone files created.

    bind is running chrooted in /var/lib/named and ispconfig is configured to put zone files in /var/lib/named/zone . ispconfig does successfully create a root.hints and in that directory but thats it. No other zone files.

    The settings are being stored in ISPConfig web interface, just not written to the named config.

    Where can I start to debug this?
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Check the ISPConfig log file: /home/admispconfig/ispconfig/ispconfig.log
  3. TexasTaz

    TexasTaz New Member

    Re: Named - DNS

    Hey everyone,

    I used Mandriva to install this and I noticed when I went to the control panel afterwords (the install), therewas no zone file for my system I put the fqdn in during the install so why didn't it create the zone files I need? At this point how do we create and set the Domain for ISPConfig.


    P.S. /home/admispconfig/ispconfig/ispconfig.log <- I looked here but didn't see anything out of the ordinary.
  4. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig doesn't create any zone files during installation (why should it?).
    Please use the DNS Manager to create zones.
  5. wangster

    wangster New Member

    When I use DNSManager as the admin user it does not create any zone files. When a user checks the "create dns" "create mx" check boxes it does create the zone files but they are a total mess.

    The zone records have multiple mx and www entries. It seems that ISPConfig does not do a sanity check before writing and just creates the same entries over and over every time the user submits that form.
  6. falko

    falko Super Moderator ISPConfig Developer

    Something seems to be wrong with your installation. Any errors in /home/admispconfig/ispconfig/ispconfig.log?
    Which distribution and ISPConfig version do you use?
  7. wangster

    wangster New Member

    Sorry for the slow reply but I was off on other projects.

    This is ISPConfig-2.2.10. There is nothing suspicious in ispconfig.log at all. In fact I see no log messages about DNS whatsoever.

    I'm thinking we may be struggling with the named.conf, and zonefiles dir settings. What is the correct settings for these in a SUSE 10 environment thats running a chrooted bind?

    We want to use /var/lib/named/zone ?

    SUSE seems to expect its changes in /etc/named.conf and then it copies them over to the chrooted directory when it starts up. That much seems to be working but no matter what I set for the zonefiles dir, no zone files are created when I'm managing it through the ISPConfig DNS Manager interface.
  8. wangster

    wangster New Member

    Just a quick follow up to myself; one problem seems to be that if I set /var/lib/named/zone as the zonefiles directory, ISPConfig writes that in named.conf as the named "directory" setting.

    That means name chroots itself to /var/lib/named, then tries to change to /var/lib/named/zone, which means it ends up looking for /var/lib/named/var/lib/named/zone which doesn't exist.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you will have to create or symlink the missing directory. Have a look at the perefct setup guides to see how a working chroot setup for ISPConfig with bind can be installed.
  10. wangster

    wangster New Member

    Ok, I'm sure I can figure out how to do it with symlinks but I just want to point out that I might be looking in the wrong place but there is no mention of symlinks in the OpenSUSE 10.2 perfect install.
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please just follow exactly the steps described in the perfect setup, it works perfectly with ISPConfig, I setup it several times this way.

Share This Page