No Webserver response When coming from the Internet

Discussion in 'Server Operation' started by GBoy810, Apr 5, 2012.

  1. GBoy810

    GBoy810 New Member

    I have installed an OpenSUSE 12.1 server with Apache, PHP, MYSQL and ownCloud. The Internal address for the server is static 192.168.1.5 and I can access ownCloud from any PC on the internal network. Everything ownCloud related works fine. Now, when I try to access the ownCloud server from outside the local network I get a browser error. Now, i checked the router and I see in the log file of the router the request for port 80 and I have enabled forwarding the HTTP traffic on the router for port 80 to the server with the address 192.168.1.5. I checked listen.conf file and there port 80 is also enable.d What did I miss?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you open port 80 in your router's firewall?

    You might also want to check if your ISP is blocking port 80.
     
  3. GBoy810

    GBoy810 New Member

    When I am on my router I see the IP address of the requesting machine for port 80. I also use WinTV Extend from Hauppauge (internet video server) on a different PC on the network using port 7799 and I am routed to that PC and it works perfectly. How I can check that port 80 is requested on the OpenSUSE server?
     
  4. GBoy810

    GBoy810 New Member

    Ok, I figured it out.

    It seems that the router is not properly forwarding HTTP requests for port 80. I changed the webserver to listen to port 7798 (file /etc/appache2/listen.conf) and updated the router to forward all HTTP requests on port 7798 to the server. Now it works.
     

Share This Page