No webmail???

Discussion in 'Installation/Configuration' started by Etienne, Mar 18, 2009.

  1. Etienne

    Etienne New Member

    Hi everybody,

    I have the following question, I have installed ISPconfig with the Perfect server Debian Lenny, everything went fine, without any problem, but now I have one issue.

    I can not get to my webmail, I can open it when I go to IP-adress\webmail, but I cannot open it when I go to web-worlds.com\email, but the controlpanel opens both ways, so does phpmyadmin and statistics??

    Please help.

    Etienne
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Which ISPConfig version?
    2) Which webmail package?
     
  3. Etienne

    Etienne New Member

    Ahh yes, forgot...

    It is ISPConfig 3 and the webmail is the Squirelmail that is installed with the Perfect Server Setup.

    Thanks,
    Etienne
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can open the webmail only like this if you did not craete any IP based websites for this IP address. Please open the settings of every webiste and select '*' instead of the IP address.

    If you really need a IP based website instead of a name based, then you can e.g. create a symlink in this website that points to the webmail installation.
     
  5. Etienne

    Etienne New Member

    That is the setting for my (at the moment) only website a * in the field IP adres, any other suggestions ??

    Kind regards,
    Etienne
     
  6. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Edit ****
    I see this in the error.log
    Code:
    [Wed Mar 18 18:08:36 2009] [error] [client 80.145.44.198] SoftException in Application.cpp:202: Script "/var/www/webmail/index.php" resolving to "/usr/share/squirrelmail//index.php" not within configured docroot
    [Wed Mar 18 18:08:36 2009] [error] [client 80.145.44.198] Premature end of script headers: index.php
    [Wed Mar 18 18:09:17 2009] [error] [client 80.145.44.198] SoftException in Application.cpp:202: Script "/var/www/phpmyadmin/index.php" resolving to "/usr/share/phpmyadmin/index.php" not within configured docroot
    
    How do I add this to the docroot?
    ***************************

    Edit 2 *****************
    I have suPHP installed
    Removing suPHP resolved the problem.
    But how do I use suPHP and this folder?
    **********************

    I have the same problem.
    Do I have to configure the Server IP to HTTP NameVirtualHost or not for this to work?

    I had my sites prior to * configured with an IP. Could it be that the change to * was not completely saved?

    the vhost of a client site looks like this:
    Code:
    <Directory /var/www/myweb.tld>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost *:80>
          DocumentRoot /var/clients/client2/web7/web
    
        ServerName myweb.tld
        ServerAlias *.myweb.tld
        ServerAdmin [email protected]
    
        ErrorLog /var/log/ispconfig/httpd/myweb.tld/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
       <Directory /var/www/myweb.tld/web>
            Options FollowSymLinks
            AllowOverride Indexes AuthConfig Limit FileInfo
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/clients/client2/web7/web>
            Options FollowSymLinks
            AllowOverride Indexes AuthConfig Limit FileInfo
            Order allow,deny
            Allow from all
        </Directory>
    
        # php as cgi enabled
        ScriptAlias /php5-cgi /var/www/php-cgi-scripts/web7/php-cgi-starter
        Action php5-cgi /php5-cgi
        AddHandler php5-cgi .php .php3 .php4 .php5
        <Directory /var/www/php-cgi-scripts/web7/>
            Order allow,deny
            Allow from all
        </Directory>
    
    </VirtualHost>
    ispconfig.vhost:
    Code:
     Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost *:8080>
      ServerAdmin [email protected]
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
      </IfModule>
    
      <IfModule mod_php5.c>
        DocumentRoot /usr/local/ispconfig/interface/web/
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
    </VirtualHost>
    and ispconfig.conf:
    Code:
    LogFormat "%v %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" comb
    ined_ispconfig
    CustomLog "| /usr/sbin/vlogger -s access.log -t \"%Y%m%d-access.log\" /var/log/i
    spconfig/httpd" combined_ispconfig
    
    <Directory /var/www/clients>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    NameVirtualHost xx.yy.zz.xyz:80
    NameVirtualHost xx.yy.zz.xyz:443
    
    default: (problem does not resolve when deleting this file)
    Code:
    NameVirtualHost *:80
    <VirtualHost *:80>
            ServerAdmin [email protected]
    
            DocumentRoot /var/www/
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
                    # This directive allows us to have apache2's default start page
                    # in /apache2-default/, but still have / go to the right place
                    RedirectMatch ^/$ /apache2-default/
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog /var/log/apache2/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog /var/log/apache2/access.log combined
            ServerSignature On
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>
     
    Last edited: Mar 18, 2009
  7. Etienne

    Etienne New Member

    Still the same problem and there IS a * in the IP adress field, and linking seems to give permission problems with user web1 in the DATA directory.

    Anybody ?

    Greetz
    Etienne
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you disable the nemvirtualhost checkbox for all IP addresses.
     
  9. Etienne

    Etienne New Member

    Done that too, but still the same :( also I dont understand why phpmyadmin is opening???

    TIA Etienne
     
  10. Tomas

    Tomas New Member

    Did you make a symbolic link after installing squirrelmail?
    Try running this command:
    Code:
    ln -s /usr/share/squirrelmail/ /var/www/webmail
     
  11. Etienne

    Etienne New Member

    Till/Tomas,

    Yes, I did, but as a precaution I just did it again, but still no webmail...

    Etienne
     
  12. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    What does the apache error.log say?
     

Share This Page