No Web Access To Login Screen

Discussion in 'Installation/Configuration' started by caffine_fizz, Apr 5, 2006.

  1. caffine_fizz

    caffine_fizz New Member

    Hi,

    I have recently followed the Ubuntu 5.10 guide to installing ISPConfig on my system, it was great; considering i've just come from the dark side of the force (MS Windows), it was good to have a guide like that to work through for beginers.

    Anyway the install went without a hitch using putty i just copied and pasted, makeing some minor changes where sugested, for running the server web based instead of localy as the guides intended. logging into the system locally doesn't seem to present a problem either using http://www.domain.com or https://www.domain.com:81 . But when you try to access the system from Web side http://www.domain.com sends me to the root /www directory and when using https://www.domain.com:81, all i get is a white/blank page with no errors.

    The server is set up on DMZ through the router so to my understanding i shouldn't need to worry about port forwarding from that end.

    There isn't any fire wall running on the server either, running iptables -L produces the following:

    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    I have worked through the forums and a few people seem to have problems similar but none seem to fix my problem. REINSTALL don't even suggest it, been there done that, three times and don't want to do it again.

    Could any one with experience of the How to tuts, or ISPConfig please help me try and fix this?
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. caffine_fizz

    caffine_fizz New Member

    the dns hosting my domain, is pointing hits to my external/web ip address, the router is then set up with DMZ, to forward all those hits to local ip adress of the host running ISPConfig.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Plesae check that your ISP does not block access to port 81.
     
  5. caffine_fizz

    caffine_fizz New Member

    ISP doesnt block 81

    Yea already checked that last night, and they say they don't block any ports

    also i was lookin through more posts today; and i noticed that in my /etc/apache2/vhosts/Vhosts_ispconfig.conf file is empty, i havn't set up anything within ispconfig from the interface (logging in through local host), with the exception of changeing my password and tried setting up a master DNS to see if that made a difference (though i'm pritty sure i don't need one).

    heres a copy ifconfig:
    eth0 Link encap:Ethernet HWaddr 00:30:BD:B2:E1:87 nsswitch.conf
    inet addr:192.168.70.100 Bcast:192.168.70.255 Mask:255.255.255.0urce
    inet6 addr: fe80::230:bdff:feb2:e187/64 Scope:Link odbc.ini
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1er odbcinst.ini
    RX packets:147797 errors:0 dropped:0 overruns:0 frame:0
    TX packets:113369 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:123482463 (117.7 MiB) TX bytes:15545171 (14.8 MiB)
    Interrupt:11 Base address:0x1400 php
    [email protected]:/var/www# editor info.php
    eth0:0 Link encap:Ethernet HWaddr 00:30:BD:B2:E1:87
    inet addr:192.168.70.101 Bcast:192.168.70.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    Interrupt:11 Base address:0x1400

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1042 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1042 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:81921 (80.0 KiB) TX bytes:81921 (80.0 KiB)

    and this is my host file:

    127.0.0.1 localhost.localdomain localhost www
    192.168.70.100 www.domain.com www
    192.168.70.101 virtual-ipl.domain.com virtual-ipl
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    And i followed the how to guide:
    http://www.howtoforge.com/perfect_setup_ubuntu_5.10


    by the way i appreciate the help, what can i try next?
     
    Last edited: Apr 7, 2006
  6. falko

    falko Super Moderator ISPConfig Developer

    Please post the output of
    Code:
    netstat -tap
    Do you get any error messages when you try to login with Firefox instead of Internet Explorer (Firefox gives better error messages)?
     
  7. caffine_fizz

    caffine_fizz New Member

    This is the contents of netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdo:mysql *:* LISTEN 13315/mysqld
    tcp 0 0 *:81 *:* LISTEN 17306/ispconfig_htt
    tcp 0 0 *:ftp *:* LISTEN 24767/proftpd: (acc
    tcp 0 0 virtual-ipl.oake:domain *:* LISTEN 24604/named
    tcp 0 0 www.oakesed.com:domain *:* LISTEN 24604/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 24604/named
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 24604/named
    tcp 0 0 *:smtp *:* LISTEN 21122/master
    tcp6 0 0 *:imaps *:* LISTEN 11242/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 11145/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 11082/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 11187/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 17334/apache2
    tcp6 0 0 *:ssh *:* LISTEN 9092/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 24604/named
    tcp6 0 0 *:https *:* LISTEN 17334/apache2
    tcp6 0 0 www.oakesed.com:ssh ::ffff:192.168.70.:1572 ESTABLISHED25651/sshd: admin [

    as for firefox - i'm installing it now, but its not the local network thats the problem it external access (web based requests) is there any chance you could have a look? i sent you the web addy in the private message.
     
    Last edited: Apr 7, 2006
  8. falko

    falko Super Moderator ISPConfig Developer

    It's working for me... Maybe a problem with your router?
     

Share This Page