No spamassassin tags

Discussion in 'General' started by noenoe, Dec 5, 2018.

  1. noenoe

    noenoe New Member

    Hi ISPConfig users,
    I'm new to this forum although I use ISPconfig for a while.
    On newly deployed server with Debian Strecht and ISPConfig 3.1.13 I don't get spamassassin tags in email headers, although I've changed policy.
    For domain I've set Spamfilter to Non-paying and this policy is set as following:
    SPAM tag level: -100
    SPAM tag2 level: -3
    SPAM kill level: 5
    SPAM dsn cutoff level: 0
    SPAM modifies subject: Yes
    Basically I receive a lot of SPAM, which is not taged and users are complaining.
    Following one similar thread on this forum I've updated ISPConfig thogheter with service reconfiguration, but this not solved the issue.
    Any hints?
  2. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    have you set the spamfilter on both the email domain and the mailbox?
  3. noenoe

    noenoe New Member

    I didn't know that I need to enable it for each user, but I've just set it also for one mailbox and did test - that did not changed anything. Still now SPAM tags.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You don't have to enable it for each user. The preferred setup is that you enable it for the email domain. Enabling it for the mailbox is useful when the policy for that specific mailbox shall differ from the domain wide setting. I guess what @nhybgtvfr referred to is that it is useful to enable it for the domain in case you had set it for the mailbox only, otherwise, emails that are received through an alias will not get tagged for spam.
  5. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You could post mail logs of a spam delivery and the message headers and maybe more will be uncovered. Amavis is what does the spam scanning, so you could enable debugging for amavis and get more detail if needed.
  6. noenoe

    noenoe New Member

    In next poast I'll post anonymized spam email header- hopefully forum reules will allow me to do so.
    So we see amavis is working, but no spamassassin tags.
  7. noenoe

    noenoe New Member

    and the headers

    Return-Path: <[email protected]>
    Delivered-To: [email protected]
    Received: from localhost (localhost.localdomain [])
    by poczta.MYDOMAIN.PL (Postfix) with ESMTP id C493E1D80099
    for <[email protected]>; Wed, 5 Dec 2018 18:24:53 +0100 (CET)
    X-Virus-Scanned: Debian amavisd-new at poczta.MYDOMAIN.PL
    Authentication-Results: poczta.MYDOMAIN.PL (amavisd-new);
    dkim=pass (1024-bit key)
    Received: from poczta.MYDOMAIN.PL ([])
    by localhost (poczta.MYDOMAIN.PL []) (amavisd-new, port 10024)
    with ESMTP id mcBfT4mLjO0O for <[email protected]>;
    Wed, 5 Dec 2018 18:24:53 +0100 (CET)
    Received: from ( [])
    by poczta.MYDOMAIN.PL (Postfix) with ESMTPS id 8BBF81D80095
    for <[email protected]>; Wed, 5 Dec 2018 18:24:53 +0100 (CET)
    DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed;; s=a;
    h=Message-Id:Date:To:List-Id:List-Unsubscribe:Content-Type:Reply-To:Subject:From:MIME-Version; bh=ql4st3vtoRzUffUg3IzpRgpsOH/l1B0rnXCwX8JiYJQ=;
    MIME-Version: 1.0
    From: "Zalando Lounge" <[email protected]>
    Subject: =?UTF-8?Q?Zalando=20Lounge,=20teraz=20a=C5=BC=20do=20-75%=20na=20LTB!=20Sprawd=C5=BA=20>>>?=
    Reply-To: [email protected]
    Content-Type: multipart/alternative;
    List-Unsubscribe: <>
    List-Id: <>
    Feedback-ID: 4091m2732:4091:newsletter:leadr
    To: [email protected]
    Date: Wed, 05 Dec 2018 18:24:53 +0100
    Message-Id: <[email protected]>
  8. noenoe

    noenoe New Member

    I did amavis debug and I've found following line for every email check
    bypassing of spam checks requested for all recips
    So I was looking for any check box on ispconfig panel but I coudln't find any.
    Fortunately I've found directly in db table policy_name field bypass_spam_checks. It was magically set to Y only for my Non-paying policy. When set to N, all works fine.

    I'm just curious where in the panel I can change this?
  9. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    FWIW, I see the same thing here, the Non-paying policy (and no others) has bypass_spam_checks set to Y.

    I don't see a place, my guess is it's hard-coded in the installer.

Share This Page