No Spam tags in headers of message

Discussion in 'HOWTO-Related Questions' started by Manuel, Oct 27, 2009.

  1. Manuel

    Manuel New Member

    My mail server is set up so that spam mails are discarded, sent to a quarantine and then to the users´s maildirs without problems (except that in the process messages become not readable because there is no separation between headers and body! but that´s another story: see post http://www.howtoforge.com/forums/showthread.php?t=40373). As for their spammy condition they get correctly tagged by spamassassin in the headers and everything is fine.

    So now I´m thinking about sending spam to the users inbox, so these are the settings in 20-debian_defaults:

    #$QUARANTINEDIR = "$MYHOME/virusmails"; # spam quarantine, not for virus
    $sa_spam_subject_tag = '***SPAM*** ';

    $final_spam_destiny = D_PASS;
    #$final_spam_destiny = D_DISCARD;

    The log is like that (it looks fine):

    Oct 27 11:55:49 correo amavis[19570]: (19570-04) Passed SPAM, [213.4.129.24] [88.25.147.89] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: 0h6TxrVntCmK, Hits: 8.889, 6440 ms
    Oct 27 11:56:06 correo amavis[19430]: (19430-09) Passed SPAM, [109.165.180.22] [109.165.180.22] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: WXjelE-+xN63, Hits: 17.76, 8265 ms

    The spam mail gets OK (they are readable) in the user´s inbox but they don´t get tagged in the headers nor in the subject so it will be certainly difficult for the users to know about what is spam and what is not. Any ideas?

    Manuel
     
    Last edited: Nov 9, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    How exactly did you set up your server? Did you use a tutorial from here? If so, what URL?
     
  3. Manuel

    Manuel New Member

  4. falko

    falko Super Moderator ISPConfig Developer

    What spam scores are you using in your amavisd configuration?

    Is this a Debian Etch server, or is it Lenny?
     
  5. Manuel

    Manuel New Member

    Finally I got it right! I was wrong about a few things in the settings I had in 20-debian_defaults:

    #$QUARANTINEDIR = "$MYHOME/virusmails"; # spam quarantine, not for virus
    $sa_spam_subject_tag = '***SPAM*** ';
    $final_spam_destiny = D_PASS;
    #$final_spam_destiny = D_DISCARD;

    and this is right
    $QUARANTINEDIR = "$MYHOME/virusmails"; # spam quarantine, not for virus
    $sa_spam_subject_tag = '***SPAM*** ';
    #$final_spam_destiny = D_PASS;
    $final_spam_destiny = D_DISCARD;

    I just came across a unique guide which explains amavis-new settings and followed it to the letter. It's url http://www200.pair.com/mecham/spam/amavisd-settings.html
    You have to set $sa_tag_level_deflt to undef or -9999 and the most important $sa_kill_level_deflt = is the score where mails are thrown into the quarantine.
    $sa_tag2_level_deflt = is the score where the subject is rewritten. In between these two levels the mails pass to the users with their subject rewritten.
    You have to get local_domains_maps right or things won't work.

    Thanks everybody

    Manuel
     
  6. Manuel

    Manuel New Member

    Hi Falko! our posts crossed! I just posted my solution (in Etch) a moment ago. I'm still not sure about $sa_kill_level_deflt . I've set it to 12.

    Thanks for your interest

    Manuel :)
     

Share This Page