No Spam Score in Mail Headers

Discussion in 'General' started by mojosound, Dec 3, 2006.

  1. mojosound

    mojosound New Member

    I recently reinstalled Mandriva 2007 and did the Perfect Setup. The Mail server is working fine as far as I can tell, except that the spam score is no longer in the headers. When I had installed before there was. Is there a way to get the headers back?

    Example header:
    Return-Path: <>
    X-Original-To: [email protected]
    Delivered-To: [email protected]
    Received: from mail19.messagelabs.com (unknown [193.109.254.3]) by server1.cjt-design-server.com (Postfix) with SMTP id A3F271518A3 for <[email protected]>; Sun, 3 Dec 2006 16:51:31 -0500 (EST)
    X-VirusChecked: Checked
    X-Msg-Ref: server-2.tower-19.messagelabs.com!1164633599!37800260!1
    X-StarScan-Version: 5.5.10.7; banners=oikocredit.org,-,-
    X-Originating-IP: [62.177.205.50]
    Received: (qmail 12992 invoked from network); 27 Nov 2006 13:20:00 -0000
    Received: from 62-177-205-50.dsl.bbeyond.nl (HELO mail.oikocredit.org) (62.177.205.50) by server-2.tower-19.messagelabs.com with SMTP; 27 Nov 2006 13:19:59 -0000
    From: [email protected]
    To: [email protected]
    Date: Mon, 27 Nov 2006 14:24:20 +0100 (08:24 EST)
    MIME-Version: 1.0
    X-Security: MIME headers sanitized on server1.cjt-design-server.com See http://www.impsec.org/email-tools/sanitizer-intro.html for details. $Revision: 1.138 $Date: 2003-01-26 11:25:54-08
    X-Security: The postmaster has not enabled quarantine of poisoned messages.
    Content-Type: multipart/report; report-type=delivery-status; boundary="9B095B5ADSN=_01C70C202618379C000040D7mail.oikocredit."
    X-DSNContext: 335a7efd - 4523 - 00000001 - 80040546
    Message-ID: <[email protected]>
    Subject: Delivery Status Notification (Failure)
    X-Virus-Status: No
    X-Virus-Checker-Version: clamassassin 1.2.3 with clamscan / ClamAV 0.88.6/2272/Sun Dec 3 06:09:40 2006
    Status:
    X-Evolution-Source: pop:[email protected]/
     
  2. mojosound

    mojosound New Member

    Follow Up

    As a followup, there is no bin folder in /home/admispconfig/tools/spamassassin/usr

    I believe that spamassassin was installed by default by the os. Should I uninstall and then recompile or can I configure ispconfig to use the installed spam assassin?
     
  3. mojosound

    mojosound New Member

    still no spamassassin

    I have uninstalled spamassassin and then recompiled ispconfig. There is still no bin directory for spamassassin. All of the perl modules are installed. Please help.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you got any errors during compilation?
     
  5. mojosound

    mojosound New Member

    compiling

    No errors reported when compiling spamassassin. The last line I see is a chmod 755 /home/admispconfig/ispconfig/tools/spamassassin/usr/share/spamassassin
     
  6. mojosound

    mojosound New Member

    Resoved

    I installed the spamassassin files that came with my distro and created a filter/script file and added to the postfix master.cf file as per a howto I found online. Now everything seems to work ok. I understand that the ispconfig settings for spamassassin wil now no longer be valid, but I am using this for personal use and am in control of all sites anyways so this is not a problem. At some point I would like to go back and revisit why the install did not work through isp config, but for right now it is doing what I want.
     

Share This Page