No sites after changing apache to nginx [Solved]

Discussion in 'ISPConfig 3 Priority Support' started by Ark74, Jan 30, 2018.

  1. Ark74

    Ark74 Member HowtoForge Supporter

    Hi guys!,

    So I did make the change from Perfect Server ISPConfig + Apache to Nginx as previously commented.
    I'm not used to nginx so I'm a little cold here.

    The issue is that following the post after patching some details (php5 vs php7) I got my ISPConfig interface back, used php -q update.php to restart all services and the system seems stable.
    The issue is that every domain is still on the apache2 sites-enabled directory, new domains are also created there.
    If you ask, I did change apache on the ispconfig database, it recognize nginx as the system webserver.

    So I'm not sure why it is still creating configuration hosts at the apache directory, if "Nginx Vhost config dir" points to /etc/nginx/sites-available
    I would appreciate your experience and advice ;-)
     
  2. Ark74

    Ark74 Member HowtoForge Supporter

    Just in case, here the ls -al (/etc/nginx/sites-enabled)

    lrwxrwxrwx 1 root root 37 Jan 29 23:52 000-apps.vhost -> /etc/nginx/sites-available/apps.vhost
    lrwxrwxrwx 1 root root 42 Jan 29 23:27 000-ispconfig.vhost -> /etc/nginx/sites-available/ispconfig.vhost
    lrwxrwxrwx 1 root root 34 Jan 29 22:29 default -> /etc/nginx/sites-available/default


    Am I missing some file?
     
  3. Ark74

    Ark74 Member HowtoForge Supporter

Share This Page