No show update state in Debain v6.

Discussion in 'Installation/Configuration' started by Mic-net, Jun 24, 2012.

  1. Mic-net

    Mic-net New Member

    Hi, please help me.
    I use Linux Debian 6 (In Linux Debian 5 it works.) and ISPConfig v3.0.4.6

    In "Monitor" -> "Show Update Status" Does not show any text showing the status updates, only shows the colored strip which means that it is green, so no update is not ready OS.

    This problem occurs on all my 3 servers where the Debian version 6.

    Any idea?
     
  2. year

    year New Member

    hello

    sorry for the gravedigging but I have the same probleme:

    I upgraded from debian 6( squeeze ) to debian 7 ( wheezy ) on an ipsconfig 3.0.5.2 install.

    In "Monitor" -> "Show Update Status" Does not show any text showing the status updates, only shows the colored strip which means that it is green, so no update is not ready OS.
    And Blue when updates needed but no list is written.

    can someone help?

    Thank you.
     
  3. kike

    kike New Member

    reinstall graphic card driver
     
  4. year

    year New Member

    IT is a headless server. So their is no need of a graphic card...
    The only part that does not show any text is raid and system update. But the rest is working fine.
     
  5. kike

    kike New Member

    you say: "In "Monitor" -> "Show Update Status" Does not show any text showing the status updates, only shows the colored strip which means that it is green, so no update is not ready OS."

    this is a graphic front end.
     
  6. year

    year New Member

    here is a print screen of my probleme.

    I think it is more related to a capture of the text of "apt-upgrade update" on a wheezy installation.

    But then again I can be wrong.

    [​IMG]

    The general overview work fine... :

    [​IMG]
     
  7. till

    till Super Moderator

    Which output do you get on the shell for this command:

    apt-get -s -qq dist-upgrade
     
  8. year

    year New Member

    I get none with
    Code:
    apt-get -s -qq dist-upgrade
    but with
    Code:
    apt-get -s -q dist-upgrade
    i get :

    Code:
    Lecture des listes de paquets...
    Construction de l[COLOR="Red"]'[/COLOR]arbre des dépendances...
    Lecture des informations d[COLOR="red"]'[/COLOR]état...
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    
    Because I just did the updates..

    I seams that the text is not transferd to the database...
    dbispconfig -> monitor_data -> system_update :

    a:1:{s:6:"output";s:0:"";}

    and i also think that it has to do with my french apt and the " ' " showed in the red in the text up there
     
    Last edited: May 2, 2013
  9. year

    year New Member

    I tried that in /usr/local/ispconfig/server/lib/classes/monitor_tools.inc.php

    Code:
      $data['output'] = htmlspecialchars(shell_exec('apt-get -s -q dist-upgrade'),ENT_QUOTES,'UTF-8'); 
    I let you Know how it turns out

    EDIT:
    nope no change
    Now i'll try :*
    Code:
    $data['output'] = str_replace("'"," ",shell_exec('apt-get -s -q dist-upgrade')); 

    EDIT2:
    Still nothing

    Now i'll try :
    Code:
    $data['output'] = addslashes(shell_exec('apt-get -s -q dist-upgrade')); 
    EDIT3:
    no more luck...


    wierd part:

    with that :
    Code:
                            $data['output'] = 'test1'.shell_exec('apt-get -s -q dist-upgrade');
                            $data['output'] = 'test2 '.addslashes($data['output']);
    
    nothing is written not even test2
     
    Last edited: May 2, 2013
  10. year

    year New Member

    If I set my apt-get to english it work normaly but in french there is not output in the DB...
     
  11. year

    year New Member

    I opened au bug track about that.
     

Share This Page