no SASL authentication mechanisms | after i followed "Securing Your ISPConfig 3[..]"

Discussion in 'General' started by cionoiu, Dec 10, 2014.

  1. cionoiu

    cionoiu New Member

    Ok, first at all, i'm a newbie with SSL/TLS.

    - I have bought a vps from ovh with plesk but i liked more ispconfig, so,
    - I followed the tutorial from here > < everything seemed to work ok.
    - I've added 2 domains and when i tried to add an SSL certificate to one of them from ISPCONFIG, nothing changed on that domain (no errors on nginx,postix,etc). Mail was working, but the mail was getting in spam.
    - I said ok, maybe i have to follow this tutorial > < and after that i should add separate certificates on each domain.
    - After i finished, 0 domains (websites) working ( i got nginx fail at part 5, when restarting nginx, but it was a missing line between the chain certificate ), dovecot is out.
    - Where should i look for the problem ? Bellow is my nginx error log

    (missing line between the chain certificate, nginx is now starting, websites not working )

    mail log

    Should i post postconf -n and dovecot -n ?
    Thanks in advance for any advice !
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the file /usr/local/ispconfig/interface/ssl/ispserver.crt, it seems as if there are either wrong line endings or additional chars in that file at the end.
  3. cionoiu

    cionoiu New Member

    i've checked ispconfig.crt

    has 3 certificates inside, but i don't know why.. the first one is the start ssl certificate for my domain, but the second one is the same with the third one, and it's the chaining certificate (
    and ).

    i removed the third one. domains are working ( ssl for domains not working, added from ispconfig admin ). dovecot still dead.


Share This Page