NO POP3!!! Ubuntu 7.10 Perfect Server

Discussion in 'Installation/Configuration' started by captnops, Jan 23, 2008.

  1. captnops

    captnops New Member

    Everything is configured and 90% working.

    Postfix SMTP is fine. I can send mail without problem.
    The user on the server can receive mail without problem (mail shows in users maildir)

    I can telnet to the pop3 server via SSH with the following command: telnet localhost 110.

    When I run "telnet mail.justoutboards.com 110" via SSH, I receive the following error:

    " telnet mail.justoutboards.com 110
    Trying 69.37.171.190...
    telnet: Unable to connect to remote host: Connection refused"


    I cannot telnet to pop3 server from outside the environment using either IP address or FQDN.

    Any help would be greatly appreciated.
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    Thats definitely a firewall blocking your connection
     
  3. captnops

    captnops New Member

    Thank you for the help. I have control over the firewall on this circuit and I have allowed port 110.

    Any other thoughts?

    Thank you for the help.

    Todd
     
  4. topdog

    topdog Active Member HowtoForge Supporter

    Please supply the output of this
    Code:
    netstat --ntlp
    
    And you can also run a tcpdump and see what is happening to the packets
    Code:
    tcpdump -tlni eth0 port 110
    
    Then connect from outside.
     
  5. captnops

    captnops New Member

    netstat output:


    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 3973/mysqld
    tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 4600/perl
    tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 4409/apache2
    tcp 0 0 0.0.0.0:81 0.0.0.0:* LISTEN 4374/ispconfig_http
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 4578/proftpd: (acce
    tcp 0 0 10.10.10.125:53 0.0.0.0:* LISTEN 4545/named
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 4545/named
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 4545/named
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 4501/master
    tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 4409/apache2
    tcp6 0 0 :::993 :::* LISTEN 4087/couriertcpd
    tcp6 0 0 :::995 :::* LISTEN 4122/couriertcpd
    tcp6 0 0 :::110 :::* LISTEN 4100/couriertcpd
    tcp6 0 0 :::143 :::* LISTEN 4067/couriertcpd
    tcp6 0 0 :::22 :::* LISTEN 3879/sshd
    tcp6 0 0 ::1:953 :::* LISTEN 4545/named
    tcp6 0 0 :::25 :::* LISTEN 4501/master



    I dont appear to have tcpdump installed.
     
  6. topdog

    topdog Active Member HowtoForge Supporter

    Am not sure but it seems like courier is only listening to ipv6 not ipv4
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Is your server behind a router? If so, does the router forward port 110 to your server?
     

Share This Page