No PHP MySQL functions available Warning while Installaing ISPConfig3

Discussion in 'Installation/Configuration' started by PC Networks, Feb 6, 2013.

  1. PC Networks

    PC Networks New Member

    Hello HTF users and moderators...

    Working with a clean installation and the HowTo:The Perfect Server - Ubuntu 12.10

    32bit machine


    I have worked through the HT and got snagged on the end portion involving the installation of ISPConfig3.


    PHP Version:
    Code:
    5.4.11



    Code:
    php-mysql
    INSTALLED



    PHP Installation Method: FastCGI


    After running
    Code:
    php -q install.php
    ISPConfig3 installation starts, and I am able to provide Language, Method, and FQDN


    Then ISPConfig3 install complains:
    Code:
    No PHP MySQL functions available. Please ensure that the PHP MySQL module is loaded.
    Output of: netstat -tap | grep mysql



    Code:
    tcp        0      0 *:mysql                 *:*                     LISTEN      1230/mysqld
    
    I have searched the HTF community and located a few complaints of the same issue from users utilizing different HTF Perfect Server solutions which involves the use of ISPCOnfig3, anything suggested in those posts I have tried with failure though.

    Thanking you in advance for your help
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The Ubuntu php mysql package is named php5-mysql and not php-mysql. Please install all packages as described in the guide.

    To install the missing package, run:

    apt-get install php5-mysql
     
  3. PC Networks

    PC Networks New Member

    php5-mysql Was Installed, Just My Omission During Original Post for Support

    Simply an omission on my behalf during the original post.

    Code:
    php5-mysql
    IS installed...

    Below you will find this mornings output after attempting to install
    Code:
    ph5-mysql
    again.

    Code:
    root@pcnetwork:~# apt-get install php5-mysql
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    php5-mysql is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    5.4.11 is a really new PHP version. I doubt it was installed through apt - I guess it was built manually, and MySQL support was left out.
     
  5. PC Networks

    PC Networks New Member

    Hey Falko

    Thanks for the reply.

    Yeah when I did the installation I went to php.net and looked over their downloads page and was ONLY able to locate 5.4.11.
    http://www.php.net/downloads.php

    I installed php 5.4.11 VIA wget

    Should I uninstall php 5.4.11 or what might you suggest?

    Thank you Falko
    Best Regards
     
  6. falko

    falko Super Moderator ISPConfig Developer

    You must recompile it, but with MySQL support.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so you did not follow the Ubuntu installation instructions like you claimed above....
     
  8. PC Networks

    PC Networks New Member

    I was kind of forced to vary as the night I was attempting to download 5.3.18 as defined in the Tutorial the system indicated that the file could not be found.
    That was when I varied from the Tutorial and went to http://www.php.net/downloads.php and found version 5.4.11, I simply didn't figure that the version change would cause issue...

    Other than difference in version of php I did adhere however.
     
    Last edited: Feb 13, 2013
  9. falko

    falko Super Moderator ISPConfig Developer

  10. PC Networks

    PC Networks New Member

    I used apt-get remove and backed out of all previous software installations.

    I followed the Tutorial, up til page 5, when I attempt to use the link:
    Code:
    wget http://olivier.sessink.nl/jailkit/jailkit-2.15.tar.gz
    Using the above URL returned the following error:
    Code:
    --2013-02-15 20:23:28--  http://olivier.sessink.nl/jailkit/jailkit-2.15.tar.gz
    Resolving olivier.sessink.nl (olivier.sessink.nl)... failed: Temporary failure in name resolution.
    wget: unable to resolve host address `olivier.sessink.nl'
    
    So I Googled jailkit-2.15, the following download file succeeded.

    Code:
    wget http://fossies.org/unix/privat/jailkit-2.15.tar.gz
    Once again however, when time to install ISPConfig3 the system still returns:
    Code:
    No PHP MySQL functions available. Please ensure that the PHP MySQL module is loaded.root@pcnetwork:/tmp/ispconfig3_install/install# ensure that the PHP MySQL module is loaded
    -bash: ensure: command not found
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Jailkit has nothing to do with PHP.

    You mut make sure to include MySQL in the ./configure line when you build PHP.
     
  12. PC Networks

    PC Networks New Member

    Hey Falko
    Thanks for the reply

    Yeah, I was just filling you in on variance(s) I encountered.

    Following is the code I used during the .configure process

    Code:
    ./configure \
      --prefix=/opt/php-5.3.18 \
      --with-pdo-pgsql \
      --with-zlib-dir \
      --with-freetype-dir \
      --enable-cgi \
      --enable-mbstring \
      --with-libxml-dir=/usr \
      --enable-soap \
      --enable-calendar \
      --with-curl --with-mcrypt \
      --with-zlib \
      --with-gd \
      --with-pgsql \
      --disable-rpath \
      --enable-inline-optimization \
      --with-bz2 \
      --with-zlib \
      --enable-sockets \
      --enable-sysvsem \
      --enable-sysvshm \
      --enable-pcntl \
      --enable-mbregex \
      --with-mhash \
      --enable-zip   \
      --with-pcre-regex \
      --with-mysql \
      --with-pdo-mysql \
      --with-mysqli \
      --with-jpeg-dir=/usr \
      --with-png-dir=/usr \
      --enable-gd-native-ttf \
      --with-openssl \
      --with-libdir=/lib/i386-linux-gnu 
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Does it work?
     
  14. PC Networks

    PC Networks New Member

    Thank you Falko

    Unfortunately, no, it does not work.
    I still encounter the original PHP MySQL error warning still.
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Did you restart Apache?
     
  16. PC Networks

    PC Networks New Member

    I re started apache2 and even tried rebooting the system.
    The same err still is generated.
     
  17. falko

    falko Super Moderator ISPConfig Developer

    Please check the output while you are building PHP. There must be some errors if MySQL functionality is missing. Or you are simply using the wrong PHP installation.
     

Share This Page