no outside ftp

Discussion in 'ISPConfig 3 Priority Support' started by kwickcut, Mar 1, 2018.

  1. kwickcut

    kwickcut Member

    i am having an issue connecting to my ftp from the outside world. if i use the internal ip 192.xxx.x.xxx i connect right away. if i use the site url i can not connect. i have checked and i have port 20-23 forwarded to the server. i really dont know what to do to fix this.

    i am running with all updates for this install

    The Perfect Server - Ubuntu 16.04 (Xenial Xerus) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1

    thanks in advance


    kwick
     
  2. kwickcut

    kwickcut Member

    this is what i get when i try to log in through filezilla
    Status: Resolving address of mysite.com
    Status: Connecting to xx.xxx.xxx.52:21...
    Status: Connection established, waiting for welcome message...
    Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response: 220-You are user number 5 of 50 allowed.
    Response: 220-Local time is now 15:53. Server port: 21.
    Response: 220-This is a private system - No anonymous login
    Response: 220-IPv6 connections are also welcome on this server.
    Response: 220 You will be disconnected after 15 minutes of inactivity.
    Command: USER aqua
    Response: 331 User aqua OK. Password required
    Command: PASS **********
    Response: 230 OK. Current restricted directory is /
    Command: SYST
    Response: 215 UNIX Type: L8
    Command: FEAT
    Response: 211-Extensions supported:
    Response: EPRT
    Response: IDLE
    Response: MDTM
    Response: SIZE
    Response: MFMT
    Response: REST STREAM
    Response: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    Response: MLSD
    Response: AUTH TLS
    Response: PBSZ
    Response: PROT
    Response: UTF8
    Response: ESTA
    Response: PASV
    Response: EPSV
    Response: SPSV
    Response: ESTP
    Response: 211 End.
    Command: OPTS UTF8 ON
    Response: 200 OK, UTF-8 enabled
    Status: Connected
    Status: Retrieving directory listing...
    Command: PWD
    Response: 257 "/" is your current location
    Command: TYPE I
    Response: 200 TYPE is now 8-bit binary
    Command: PASV
    Response: 227 Entering Passive Mode (73,226,196,52,195,128)
    Command: MLSD
    Error: Connection timed out
    Error: Failed to retrieve directory listing
     
  3. kwickcut

    kwickcut Member

    and this is the output of netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:ssh *:* LISTEN 1029/sshd
    tcp 0 0 *:smtp *:* LISTEN 1724/master
    tcp 0 0 localhost:953 *:* LISTEN 1031/named
    tcp 0 0 192.168.1.104:59327 *:* LISTEN 20409/pure-ftpd (ID
    tcp 0 0 localhost:10023 *:* LISTEN 1290/postgrey.pid -
    tcp 0 0 192.168.1.104:41384 *:* LISTEN 25971/pure-ftpd (ID
    tcp 0 0 localhost:10024 *:* LISTEN 1478/amavisd-new (m
    tcp 0 0 localhost:9000 *:* LISTEN 1027/php-fpm.conf)
    tcp 0 0 localhost:10025 *:* LISTEN 1724/master
    tcp 0 0 192.168.1.104:59050 *:* LISTEN 20019/pure-ftpd (ID
    tcp 0 0 localhost:10026 *:* LISTEN 1478/amavisd-new (m
    tcp 0 0 localhost:10027 *:* LISTEN 1724/master
    tcp 0 0 localhost:11211 *:* LISTEN 1034/memcached
    tcp 0 0 *:webmin *:* LISTEN 32392/perl
    tcp 0 0 *:urd *:* LISTEN 1724/master
    tcp 0 0 *:ftp *:* LISTEN 7516/pure-ftpd (SER
    tcp 0 0 192.168.1.104:domain *:* LISTEN 1031/named
    tcp 0 0 localhost:domain *:* LISTEN 1031/named
    tcp 1 0 192.168.1.104:ftp c-73-226-196-52.h:51106 CLOSE_WAIT 20019/pure-ftpd (ID
    tcp 0 248 192.168.1.104:ssh c-73-226-196-52.h:51511 ESTABLISHED 26786/sshd: kwick [
    tcp 0 0 192.168.1.104:ssh c-73-226-196-52.h:50308 ESTABLISHED 24998/sshd: kwick [
    tcp 1 0 192.168.1.104:ftp c-73-226-196-52.h:51206 CLOSE_WAIT 25971/pure-ftpd (ID
    tcp 1 0 192.168.1.104:ftp c-73-226-196-52.h:51128 CLOSE_WAIT 20409/pure-ftpd (ID
    tcp6 0 0 [::]:ssh [::]:* LISTEN 1029/sshd
    tcp6 0 0 [::]:smtp [::]:* LISTEN 1724/master
    tcp6 0 0 localhost:953 [::]:* LISTEN 1031/named
    tcp6 0 0 [::]:https [::]:* LISTEN 6316/apache2
    tcp6 0 0 localhost:10023 [::]:* LISTEN 1290/postgrey.pid -
    tcp6 0 0 localhost:10024 [::]:* LISTEN 1478/amavisd-new (m
    tcp6 0 0 localhost:10026 [::]:* LISTEN 1478/amavisd-new (m
    tcp6 0 0 [::]:mysql [::]:* LISTEN 1381/mysqld
    tcp6 0 0 [::]:webmin [::]:* LISTEN 32392/perl
    tcp6 0 0 [::]:http [::]:* LISTEN 6316/apache2
    tcp6 0 0 [::]:tproxy [::]:* LISTEN 6316/apache2
    tcp6 0 0 [::]:urd [::]:* LISTEN 1724/master
    tcp6 0 0 [::]:8181 [::]:* LISTEN 6316/apache2
    tcp6 0 0 [::]:ftp [::]:* LISTEN 7516/pure-ftpd (SER
    tcp6 0 0 [::]:domain [::]:* LISTEN 1031/named
    tcp6 0 0 192.168.1.104:8181 c-73-226-196-52.h:51520 ESTABLISHED 16136/apache2
     
  4. kwickcut

    kwickcut Member

    i have also done the following
    echo "40110 40210" > /etc/pure-ftpd/conf/PassivePortRange
    /etc/init.d/pure-ftpd-mysql restart

    and then added them to the firewall in ispconfig

    Open TCP ports: 20,21,22,25,53,80,110,143,443,587,993,995,3306,8080,8081,8181,10000,50001:60100
     
    Last edited: Mar 2, 2018
  5. kwickcut

    kwickcut Member

    well i think i had a router issue i went in and deleted everything for the ftp then rebooted the router .

    i then ran
    echo "40110 40210" > /etc/pure-ftpd/conf/PassivePortRange
    /etc/init.d/pure-ftpd-mysql restart

    then i went back into the router and added the forwarding again and it worked. i am thinking the router was locking the old settings and not changing not sure but it now works..


    kwick
     
    till likes this.

Share This Page