No output from server.sh

Discussion in 'Installation/Configuration' started by matric, Sep 16, 2012.

  1. matric

    matric New Member

    Hi,

    This is my first post, just want to say hi and thanks for any help in advance. :D

    Been running ISPConfig 3 for about 6 months with no real problems...until now. :(

    Current Setup
    ISPConfig - 3.0.4.6
    Centos 6.3 x86_64
    nginx/1.0.15

    Followed this guide when building the server
    http://www.howtoforge.com/perfect-server-centos-6.3-x86_64-nginx-dovecot-ispconfig-3

    Last 3 lines of ispconfig.log
    14.08.2012-11:19 - DEBUG - Deleted Cron file /etc/cron.d/ispc_chrooted_web7
    14.08.2012-11:19 - DEBUG - Processed datalog_id 769
    14.08.2012-11:19 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock


    Last 3 lines of job queue
    2012-09-13 23:23 vm....com.au Update web_domain
    2012-09-13 23:23 vm....com.au Update web_domain
    2012-09-13 23:23 vm....com.au Update web_domain


    Problem:
    Jobs are queueing up in the job queue monitor.

    What I've done so far:
    I've enable debug logging in config.inc.php
    disable server.sh cron job using crontab -e
    Rebooted the server
    Tried running server.sh as root

    Last Actions before first noticing the problem:
    Tried changing values of these options under one of the websites
    PHP-FPM pm.max_children
    PHP-FPM pm.start_servers
    PHP-FPM pm.min_spare_servers
    PHP-FPM pm.max_spare_servers

    I'd noticed they weren't changing after 10 minutes. Tried a different website same problem. Manually edited the conf files. restarted php-fpm & nginx

    I now have 11 pages of job queues. Does anybody know if there is a way I can manually delete the job that is possibly holding up the others? Or clear the job queue all together?

    Thanks again
     
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Have you enabled debug logging on the ispc interface in server confg?
    This is neccessary to get debug messages.
     
  3. matric

    matric New Member

    Thanks Croydon. I thought I had enabled it by manually editing the config.inc.php file and change the line $conf['log_priority'] = 0;. I did this because I didn't think making changes through the interface would work when the job queue was stuck.

    I'm now getting some output
    DEBUG - There is already a lockfile set. Waiting another 10 seconds....

    Thanks for your quick help. Really appreciate it. :D
     
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Ok, seems the script has died so you have to delete the lockfile.
    It is under /usr/local/ispconfig/server/temp/.ispconfig_lock

    Just delete this file and run the server script again.
     

Share This Page