No new database created after update on Muilt Server

Discussion in 'Installation/Configuration' started by, May 8, 2015.

  1. Member

    I'm facing a problem that is hard for me to solve and I need help.
    I did the update but it didn't went well (forgotten passwords).
    During the troubleshooting I changed passwords, because I forgot the originals. I know, bad documentation.
    I restored the backup, /usr/local/ispconfig and the original database (master and slave).
    After restoration, I found the old passowrds, I perform again the update and all went well. No errors.
    I can connect from the master to the db slave, and from the slave to the master.

    How can I solve this?
    I disabled the cron and run the /usr/local/ispconfig/server/ by hand, no errors.
    On the master I query the database, search, for the new one and it exists on the table web_database. Doing the same on the slave, nothing appears.
    Running PHP 5.3 and MySQL5

    Thank you.
  2. Member

    Can I remove de mysql server and add it back again? or add it with another hostname?
    If this is possible what is going to happen to the existing databases?

    Thank you
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This will break all existing databases.

    > I disabled the cron and run the /usr/local/ispconfig/server/ by hand, no errors.

    Enable debugging for this salve server in the ispconfig interface on the master, then add a new database and then run the script and post the output.
 likes this.
  4. Member

    Thank you Till,

    I was only running on the master and not on the slave.
    I found the problem and solve it. It was the username I messed up.
    Many many thanks.

Share This Page