No network from domU to outside dom0

Discussion in 'Installation/Configuration' started by philippe_, Jan 24, 2012.

  1. philippe_

    philippe_ New Member

    Hello!

    I have successfully installed xen and run a domU on a debian squeeze.

    I have followed step by step the tutorial from Falko here. I can log in my domU by SSH but from the domU I can't connect to anything but the dom0 itself.

    Can anyone help me to enable network from my domU to the ouside?

    Here is my xend-config.sxp file:
    Code:
    root@namaka-xen:/etc/xen# grep -Evn "^#|^$" xend-config.sxp 
    145:(network-script 'network-bridge')
    176:(vif-script vif-bridge)
    193:(dom0-min-mem 196)
    197:(enable-dom0-ballooning yes)
    207:(total_available_memory 0) 
    211:(dom0-cpus 0)
    226:(vncpasswd '')
    root@namaka-xen:/etc/xen#
    Here is my domU.cfg file:
    Code:
    root@dom0:/etc/xen# cat domU.cfg 
    #
    # Configuration file for the Xen instance domU, created
    # by xen-tools 4.2 on Tue Jan 24 10:59:20 2012.
    #
    
    #
    #  Kernel + memory size
    #
    kernel      = '/boot/vmlinuz-2.6.32-5-xen-686'
    ramdisk     = '/boot/initrd.img-2.6.32-5-xen-686'
    
    vcpus       = '1'
    memory      = '128'
    
    #
    #  Disk device(s).
    #
    root        = '/dev/xvda2 ro'
    disk        = [
                      'file:/data/xen/domains/domU.telergos.net/disk.img,xvda2,w',
                      'file:/data/xen/domains/domU.telergos.net/swap.img,xvda1,w',
                  ]
    
    #
    #  Physical volumes
    #
    
    #
    #  Hostname
    #
    name        = 'namaka-vm.telergos.net'
    
    #
    #  Networking
    #
    vif         = [ 'ip=172.23.154.105,mac=00:16:3E:04:8E:7A']
    
    #
    #  Behaviour
    #
    on_poweroff = 'destroy'
    on_reboot   = 'restart'
    on_crash    = 'restart'
    I don't have any xenbr when I run ifconfig:
    only eth0, peth0, lo and vif1.0

    When I run tshark -f '!port 22' I can see ARP requests when I try to ping others hosts than my dom0 but no answer. It looks like these ARP packets ar stuck in the dom0 host.

    Here is iptables -L output:
    Code:
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED PHYSDEV match --physdev-out vif1.0 
    ACCEPT     udp  --  anywhere             anywhere            PHYSDEV match --physdev-in vif1.0 udp spt:bootpc dpt:bootps 
    ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED PHYSDEV match --physdev-out vif1.0 
    ACCEPT     all  --  namaka-vm.telergos.net  anywhere            PHYSDEV match --physdev-in vif1.0
    I am ways too newbie to fully understand this configuration, but it looks like it is applied at boot time.

    I have thought that dom0 may not know what to do with domU packets, but do0 is supposed to act as a bridge! So, it should simply relay these packets on its eth0 interface, letting my switch relay them on the others hosts...

    Thank you for your time and help!
     
  2. falko

    falko Super Moderator

    Did you specify the correct network settings (IP, netmask, gateway) when you created the VM?
     
  3. nzimas

    nzimas New Member

    I have a somewhat similar scenario here, although I can't even make it to the VM through SSH (I am having his issue with KVM too, btw)
    My setup follows Falko's howto (the part concerning image based machines).

    The physical host has only one physical NIC which holds the public IP, gateway and so forth.

    Do I need a second physical NIC in order to create an internal network? I would think I don't, but at the same time I have this eerie feeling I do.

    This is how the dm0 interfaces look like:
    This how the domU interface looks like
    The gateway on dom0 and domU is not the same probably because I do not have a second NIC or a working virtual interface.

    Networking is where I am stck in all my virtualization attempts :(
     
  4. nzimas

    nzimas New Member

    In my case, looks like OVH itself is the roadblock.

    Just great.
     
  5. nzimas

    nzimas New Member

    NAT insteaed of bridge, of course.
    All in all, I only want the guests to accessed from the host.
     
: networking, xen

Share This Page