No name server could be found

Discussion in 'ISPConfig 3 Priority Support' started by OwnYourOwn, Sep 18, 2014.

  1. OwnYourOwn

    OwnYourOwn New Member HowtoForge Supporter

    Hello

    Running Debian 7.6 / Apache and Ispconfig 3.0.5.4p2.

    For all domains installed using ISPConfig, I get the following Domain Configuration error when checking with 4 different internet DNS services.

    Running domain configuration checks for mydomain.com...
    Name Servers Exist Received answer from ns2.nameserver.net
    The name servers for this domain are:
    ns1.nameserver.net
    ns2.nameserver.net Pass

    Name Server Count You have 2 name servers. Pass

    Name Server Glue Server returned no 'glue' records. Warn

    Name Server Authority
    Checking name server authority:
    ns1.nameserver.net : no nameservers
    ns2.nameserver.net : no nameservers Fail
    One or more name servers is not authoritative for this domain.
    No name server could be found.
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    When doing a DNS Lookup, they're all good:
    Name Type TTL Value
    mydomain.com A 3600 123.45.678.90

    Name Type TTL Value
    mydomain.com NS 3600 ns2.nameserver.net.
    mydomain.com NS 3600 ns1.nameserver.net.

    Name Type TTL Value
    mydomain.com SOA 3600 ns1.nameserver.net.
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    Checked ISPConfig Firewall it's Ok:
    Open TCP ports: --- 53
    Open UDP ports: 53 ---
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    When doing an open port check for domain, port 53 is closed:
    mydomain.com:53 port is closed

    When doing an open port check for IP, port 53 is open:
    123.45.678.90:53 port is open

    Am able to telnet to both domain and IP address
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    When doing nslookup from server:
    [email protected]:~# nslookup
    > set querytype=soa
    > mydomain.com
    Server: 8.8.8.8
    Address: 8.8.8.8#53

    Non-authoritative answer:
    mydomain.com
    origin = ns1.nameserver.net
    mail addr = server.mydomain.com
    serial = 2014090601
    refresh = 7200
    retry = 540
    expire = 604800
    minimum = 86400

    Authoritative answers can be found from:
    >(NOTHING)
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    [email protected]:~# netstat -tunlp | grep :53

    tcp 0 0 123.45.678.90:53 0.0.0.0:* LISTEN 2357/named
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 2357/named
    tcp6 0 0 :::53 :::* LISTEN 2357/named
    udp 0 0 123.45.678.90:53 0.0.0.0:* 2357/named
    udp 0 0 127.0.0.1:53 0.0.0.0:* 2357/named
    udp6 0 0 :::53 :::* 2357/named
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    [email protected]:~# dig 123.45.678.90 mydomain.com

    ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> 123.45.678.90 mydomain.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 20806
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;123.45.678.90. IN A

    ;; AUTHORITY SECTION:
    . 1796 IN SOA a.root-servers.net. nstld.verisign-grs.com. 2014091701 1800 900 604800 86400

    ;; Query time: 8 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Wed Sep 17 15:02:17 2014
    ;; MSG SIZE rcvd: 106

    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31046
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, (MY NOTE: AUTHORITY S/B 1) ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mydomain.com. IN A

    ;; ANSWER SECTION:
    mydomain.com. 3599 IN A 123.45.678.90

    (MY NOTE: NO AUTHORITY SECTION)

    ;; Query time: 110 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Wed Sep 17 15:02:17 2014
    ;; MSG SIZE rcvd: 51
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    Would appreciate help in resolving error: No name server could be found

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run the following command on the server and post the output:

    dig @localhost domain.tld

    replace domain.tld with the domain name that you configured as dns record in ispconfig.
     
  3. OwnYourOwn

    OwnYourOwn New Member HowtoForge Supporter

    Thanks for your response!

    [email protected]:~# dig @localhost mydomain.com

    ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> @localhost mydomain.com
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47696
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mydomain.com. IN A

    ;; ANSWER SECTION:
    mydomain.com. 3600 IN A 123.45.678.90

    ;; AUTHORITY SECTION:
    mydomain.com. 3600 IN NS ns2.serverns.net.
    mydomain.com. 3600 IN NS ns1.serverns.net.

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Sep 18 12:26:36 2014
    ;; MSG SIZE rcvd: 104
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, so your nameserver is working. Please post the output of:

    iptables -L
     
  5. OwnYourOwn

    OwnYourOwn New Member HowtoForge Supporter

    Thans

    [email protected]:~# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-dovecot-pop3imap tcp -- anywhere anywhere multiport dports pop3,pop3s,imap2,imaps
    fail2ban-pure-ftpd tcp -- anywhere anywhere multiport dports ftp
    fail2ban-ssh tcp -- anywhere anywhere multiport dports ssh

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain fail2ban-dovecot-pop3imap (1 references)
    target prot opt source destination
    RETURN all -- anywhere anywhere

    Chain fail2ban-pure-ftpd (1 references)
    target prot opt source destination
    DROP all -- node-19hh.pool-125-27.dynamic.totbb.net anywhere
    DROP all -- dsl-189-132-233-201-dyn.prod-infinitum.com.mx anywhere
    DROP all -- 61.160.215.72 anywhere
    RETURN all -- anywhere anywhere

    Chain fail2ban-ssh (1 references)
    target prot opt source destination
    DROP all -- 122.225.109.219 anywhere
    DROP all -- 212.51.174.61.dial.wz.zj.dynamic.163data.com.cn anywhere
    DROP all -- 119.147.217.83 anywhere
    DROP all -- 77.221.144.184 anywhere
    DROP all -- euve40460.serverprofi24.com anywhere
    DROP all -- 216.50.174.61.dial.wz.zj.dynamic.163data.com.cn anywhere
    DROP all -- c-66-176-139-229.hsd1.fl.comcast.net anywhere
    DROP all -- 194.51.174.61.dial.wz.zj.dynamic.163data.com.cn anywhere
    DROP all -- 1.93.29.78 anywhere
    DROP all -- 217.51.174.61.dial.wz.zj.dynamic.163data.com.cn anywhere
    DROP all -- 222.51.174.61.dial.wz.zj.dynamic.163data.com.cn anywhere
    DROP all -- 122.225.109.116 anywhere
    DROP all -- 61.152.188.159 anywhere
    DROP all -- 92.247.179.38 anywhere
    DROP all -- 118.123.116.253 anywhere
    DROP all -- 205.51.174.61.dial.wz.zj.dynamic.163data.com.cn anywhere
    DROP all -- 222.186.34.161 anywhere
    DROP all -- 122.225.109.105 anywhere
    DROP all -- 37-128-63-162.adsl.inetia.pl anywhere
    DROP all -- 218.2.0.128 anywhere
    DROP all -- 124-248-245-6.sunnyvision.com anywhere
    DROP all -- static.49.138.251.148.clients.your-server.de anywhere
    DROP all -- 184.95.51.177 anywhere
    DROP all -- 221.192.132.195 anywhere
    DROP all -- 218.2.0.133 anywhere
    DROP all -- 198.51.174.61.dial.wz.zj.dynamic.163data.com.cn anywhere
    DROP all -- 117.21.225.169 anywhere
    RETURN all -- anywhere anywhere
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    that should be ok, as long as none of the urls that you use to connect to the dns server are listed in the drop list.
     
  7. OwnYourOwn

    OwnYourOwn New Member HowtoForge Supporter

    Thanks again.

    No, none of the server IP's are in the list.

    But I'm still getting no glue records and
    No name server could be found errors.

    Like I said I've used several different online DNS services and get the same above errors on running any domain on server.

    If you can, please try:
    http://www.webdnstools.com/dnstools/domain_check

    Domain: eyjack.com to see what I'm talking about.

    I'm also using a DigitalOceam server configured with zPanel and don't have any problems with glue or authentication. I thought it must be how I've got ISPConfig setup.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I alwaysuse intodns.com as thats quite reliable:

    http://www.intodns.com/eyjack.com

    the result is fine so far. Your domain has just no www record at the moment. Add a dns A-Record for "www" that points to the ip address of your server.
     
  9. OwnYourOwn

    OwnYourOwn New Member HowtoForge Supporter

    Thank you very much Till.

    Will use intodns.com in the future. Will fix www.

    Really appreciate your "The Perfect Server" and help!
     

Share This Page