No mechanism available

Discussion in 'Server Operation' started by sellotape, Dec 5, 2011.

  1. sellotape

    sellotape New Member


    I have uBuntu 11.10 installed and have recently been having some problems connecting to my server externally.

    I've tried the guide here:

    But have not had any luck... Instead I am receiving these error messages:

    When attempting to restart saslauthd:
    /usr/sbin/saslauthd: /usr/local/lib/ no version information available (required by /usr/lib/i386-linux-gnu/
    And postfix:

    /usr/sbin/postconf: /usr/local/lib/ no version information available (required by /usr/sbin/postconf)
    Still receiving this message too:
    Dec  5 19:55:11 squirrel postfix/smtpd[8564]: warning: unknown[ipAddress]: SASL PLAIN authentication failed: no mechanism available

    Not sure what to do next!

    Many thanks
    Last edited: Dec 5, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you install the correct packages for your architecture (i386 or x86_64)?
  3. sellotape

    sellotape New Member

    Hi Falko - I did thanks yes but had no joy. (i386)

    ISPconfig mentioned that my libsasl files were out of date so I ran apt-get upgrade which removed the error message above and replaced it with a new one when attempting to login externally..

    Dec  6 22:25:52 squirrel postfix/smtpd[2528]: warning: unknown[<ip>]: SASL PLAIN authentication failed: authentication failure
    Definitely using the right details (full email as user and correct password).

    Scratching my head with this one!

    After further poking around I suspect it could have something to do with my /etc/default/saslauthd file...

    pwcheck_method: saslauthd
    mech_list: plain login
    allow_plaintext: true
    auxprop_plugin: mysql
    sql_user: ispconfig
    sql_passwd: 580b4cbdaee49dcd6955264fe4a4cb4c
    sql_database: dbispconfig
    sql_select: select password from mail_user where login = '%u'
    Not sure if this is correct :S
    Last edited: Dec 7, 2011

Share This Page