no mail received pop3 ubuntu 6.06

Discussion in 'Installation/Configuration' started by showe1966, Feb 6, 2008.

  1. showe1966

    showe1966 New Member

    I accidentally blocked port 25 using the firewall for a few hours, and now I have problems receiving mail.
    I am using pop3 with a maildir.

    For all the logs, everything seems to be working ok , but I only get a few mails out of all the mails i should get.
    I can't understand it as i did not really change any configs.

    SMTP works fine:-

    Feb 6 21:51:24 server1 postfix/smtpd[11353]: connect from 85-18-136-77.fastres.net[85.18.136.77]
    Feb 6 21:51:24 server1 postfix/smtpd[11353]: setting up TLS connection from 85-18-136-77.fastres.net[85.18.136.77]
    Feb 6 21:51:27 server1 postfix/smtpd[11353]: TLS connection established from 85-18-136-77.fastres.net[85.18.136.77]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Feb 6 21:51:27 server1 postfix/smtpd[11353]: 64C506F566E: client=85-18-136-77.fastres.net[85.18.136.77], sasl_method=PLAIN, sasl_username=web1_info
    Feb 6 21:51:27 server1 postfix/cleanup[11626]: 64C506F566E: message-id=<[email protected]>
    Feb 6 21:51:27 server1 postfix/qmgr[10433]: 64C506F566E: from=<[email protected]>, size=662, nrcpt=1 (queue active)
    Feb 6 21:51:27 server1 postfix/smtp[11656]: 64C506F566E: to=<[email protected]>, relay=smtp.tin.it[62.211.72.32]:25, delay=0.5, delays=0.3/0.01/0.11/0.09, dsn=2.0.0, status=sent (250 <47AA15A60002DB3F> Mail accepted)
    Feb 6 21:51:27 server1 postfix/qmgr[10433]: 64C506F566E: removed
    Feb 6 21:51:28 server1 postfix/smtpd[11353]: disconnect from 85-18-136-77.fastres.net[85.18.136.77]

    here is what i see when i send myself a mail from another mailbox:-

    Feb 6 21:55:41 server1 postfix/smtpd[11715]: BFD3B6F4001: client=smtp1web.tin.it[212.216.176.195]
    Feb 6 21:55:41 server1 postfix/cleanup[11757]: BFD3B6F4001: message-id=<[email protected]>
    Feb 6 21:55:41 server1 postfix/qmgr[10433]: BFD3B6F4001: from=<[email protected]>, size=724, nrcpt=1 (queue active)
    Feb 6 21:55:41 server1 postfix/pickup[10432]: D2F026F56BF: uid=10003 from=<web1_showe>
    Feb 6 21:55:41 server1 postfix/cleanup[11757]: D2F026F56BF: message-id=<[email protected]>
    Feb 6 21:55:41 server1 postfix/local[11758]: BFD3B6F4001: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.64, delays=0.6/0/0/0.04, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Feb 6 21:55:41 server1 postfix/qmgr[10433]: BFD3B6F4001: removed


    When i go to get the message with my client, i am prompted for the certificate okay, but no message arrives.
    Here is what is in the logs on connect:-

    Feb 6 22:03:35 server1 pop3d-ssl: LOGIN, user=web1_showe, ip=[::ffff:85.18.136.77]
    Feb 6 22:03:35 server1 pop3d-ssl: Connection, ip=[::ffff:85.18.136.77]
    Feb 6 22:03:35 server1 pop3d-ssl: LOGOUT, user=web1_showe, ip=[::ffff:85.18.136.77], top=0, retr=0, rcvd=24, sent=96, time=0
    Feb 6 22:03:35 server1 pop3d-ssl: LOGIN, user=web1_info, ip=[::ffff:85.18.136.77]
    Feb 6 22:03:35 server1 pop3d-ssl: LOGOUT, user=web1_info, ip=[::ffff:85.18.136.77], top=0, retr=0, rcvd=24, sent=96, time=0

    what in the planet of hell is going on ???

    here is my postfix config, which was working fine and nothing in it was changed:-

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = server1.xxxxxxxxxx.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = server1.xxxxxx.com, localhost.xxxs.com, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject_invalid_hostname,reject_non_fqdn_hostname,reject_non_fqdn_sender,reject_invalid_hostname,reject_non_fqdn_hostname,reject_non_fqdn_sender,reject_non_fqdn_recipient,reject_unknown_sender_domain,reject_unknown_recipient_domain,reject_unauth_destination,reject_rbl_client list.dsbl.org,reject_rbl_client sbl.spamhaus.org,reject_rbl_client cbl.abuseat.org,reject_rbl_client dul.dnsbl.sorbs.net,

    smtpd_error_sleep_time = 1s
    smtpd_soft_error_limit = 10
    smtpd_hard_error_limit = 20

    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
    disable_vrfy_command = yes
    smtpd_delay_reject = yes
    smtpd_helo_required = yes
    smtpd_helo_restrictions = permit_mynetworks,

    when i telnet localhost 25 evrything works:

    [email protected]:/etc/postfix# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 server1.xxxxxx.com ESMTP Postfix (Ubuntu)
    ehlo localhost
    250-server1.xxxxxxx.com
    250-PIPELINING
    250-SIZE 10240000
    250-ETRN
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN

    the weirdest thing is i do get a few mails every now and then......
     
  2. showe1966

    showe1966 New Member

    hacked

    i think i've been hacked so i'm re-installing.

    but thatnks for the input anyway
     

Share This Page