No mail logs from Postfix

Discussion in 'Installation/Configuration' started by rojozak, Nov 24, 2006.

  1. rojozak

    rojozak New Member

    Hi Everyone,

    I've got a 'stange' problem with my mail stopped. My mail.log, mail.err,, mail.warn are all empty. There are old logs (.0, .gz) that end about a month or so ago (each different), but nothing is logging.

    I have ISPConfig w/ Ubuntu Dapper Drake (perfect setup) and Postfix. Mail works (mostly..another issue), but no logging. Any clues?

    I verified email logging in ISPConfig setup as /var/log/mail.log and have tried changing the name and restarting both ispconfig and postfix after to log an event but nothing.

    Here's my crontab:

    [email protected]:/var/log# crontab -l                                                                                   30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
    0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
    0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null
    15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
    40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
    05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null
    0 * * * * /etc/webmin/bandwidth/
    Any ideas? Thanks.
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    df -h
    ? Maybe one of your partitions is full.
  3. rojozak

    rojozak New Member

    Hi Falko...thanks for the reply.

    It looks like there's plenty of room.

    [email protected]:~# df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sdb1              32G  2.5G   28G   9% /
    varrun                126M  132K  126M   1% /var/run
    varlock               126M  4.0K  126M   1% /var/lock
    udev                  126M   60K  126M   1% /dev
    devshm                126M     0  126M   0% /dev/shm
    lrm                   126M   19M  107M  15% /lib/modules/2.6.15-27-386/volatile
    What's the process that controls these logs? The only system change that I can think of that I have made was the changing of the hostname, if that may affect it?
  4. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. What's the output of
    ls -la /var/log
    ? Are there any error messages in your logs?
  5. rojozak

    rojozak New Member

    Falko, thanks once again for your help. It appears I've solved the issue. I found that the logs just seemed to stop everyday at about 8 am. This is the sametime the bandwidth monitor of webmin runs it's rotate (see the crontab above). I shut down the bandwidth monitoring and it's all been running ok since.

    Now I get to deal with the errors that I didn't see before because of the lack of logging. Among them is a postfix/cleanup warning that the virtualusertable.db is older than the source. So, I'll be digging into that one now....I may be back for more advice!


Share This Page