No ISPConfig Page Shown.

Discussion in 'Installation/Configuration' started by JDConnors, Feb 9, 2014.

  1. JDConnors

    JDConnors New Member

  2. JDConnors

    JDConnors New Member

    I've found that it doesn't matter if you enable ssl or not, it still comes up the same way.

    Must be a symlink of some sort?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you follow the guide to the letter, or dd you leave out some instructions?

    ISPConfig uses its own vhost, this vhost file is in /etc/httpd/conf/sites-enabled/. Maybe the include in your httpd.conf for the directory /etc/httpd/conf/sites-enabled/ is missing.
     
  4. JDConnors

    JDConnors New Member

    Till,

    Followed to the letter. I didn't change anything.
     
  5. JDConnors

    JDConnors New Member

    Till,

    NameVirtualHost *:80
    NameVirtualHost *:443
    Include /etc/httpd/conf/sites-enabled/


    It's there :confused:
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, and in /etc/httpd/conf/sites-enabled/, you have a 000-ispconfig.conf and 000-ispconfig.vhost ?
     
  7. JDConnors

    JDConnors New Member

    Yes, they are both located there.
     
  8. JDConnors

    JDConnors New Member

    Guess it's stuck at that :)
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you sure that you really access the correct server? Maybe the domain points to a wrong IP or the port is forwarded in a router to a different server or the router uses port 8080 itself.
     
  10. JDConnors

    JDConnors New Member

    No router, no firewall on the box right now.

    It's located in DC and there is nothing being blocked.

    Squirrelmail works, awstats work.
     
  11. sthevan79

    sthevan79 New Member

    any solution ?
    i also getting Apache test page only

    Thanks
     
  12. JDConnors

    JDConnors New Member

    @sthevan79

    All I did was go thru the install again. I had a found a couple things I had missed and it works now.

    Probably the safest best is just verify you didn't miss a step along the way.
     
  13. sthevan79

    sthevan79 New Member

    when installation does have any error
     
  14. JDConnors

    JDConnors New Member

    Mine didn't have any errors either, but I missed putting line in.
     
  15. sthevan79

    sthevan79 New Member

    r u using centos 6 os?
     
  16. JDConnors

    JDConnors New Member

    Here is my 'fix' in another thread.


    If you are using CentOS, ensure that you have no 3rd party repo's enabled. ISPConfig needs be installed on a vanilla OS install.

    So, check, if there are other repo's disable, yum -y update and then do the install process again.
     
  17. sthevan79

    sthevan79 New Member

    what was line ur r missing , will help full if u cloud share it
     
  18. sthevan79

    sthevan79 New Member

    ok thanks for info,let me try out fist
     
  19. JDConnors

    JDConnors New Member

    Did you read what I put in the quotes?

    Regardless, the missing line would not have stopped ISP from working. 99.9999999% sure it was the enabled 3rd party repo.
     
  20. sthevan79

    sthevan79 New Member

    already remove said repo, but when access getting below page only

    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>400 Bad Request</title>
    </head><body>
    <h1>Bad Request</h1>
    <p>Your browser sent a request that this server could not understand.<br />
    Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
    Instead use the HTTPS scheme to access this URL, please.<br />
    <blockquote>Hint: <a href="https://redirector-sjl.enom.com:20000/"><b>https://redirector-sjl.enom.com:20000/</b></a></blockquote></p>
    </body></html>
     

Share This Page