No ISPConfig after reboot

Discussion in 'Installation/Configuration' started by jopa123, Nov 28, 2010.

  1. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    now? Are there any SSH errors in your logs?
     
  2. jopa123

    jopa123 New Member

    Falko,

    To test my logic I started rebuilding the box again. I'm getting so that I can do the whole thing in about 15 minutes.

    This time I only installed the base system, ssh and openssh-server, and vim-nox. I then rewrote the interfaces files so that the ip was what I wanted and tried to connect. No luck.

    Somehow my network seems to be degrading. At first I could ssh into the box all the way through the install process but couldn't ssh from within the network after reboot. After the next rebuild I could ssh right up until I completed the entire install (ISPConfig and all) and rebooted.

    Now I can't SSH even before I install all of the extra stuff.

    I suspected my router previously, but disregarded that theory when I could SSH throughout the install process. Now I am starting to think that it is my router.

    Is it possible for routers to degrade slowly like that? I had a power outage that could have affected the router, but I thought either it worked or it didn't, not a "sometimes" thing.

    I will check for ssh errors when I get home. Where is the file to check this?

    Thanks for your patience.
     
  3. jopa123

    jopa123 New Member

    One more piece of info. I just tried to ssh to localhost from within the server and got:

    The authenticity of host localhost :):1) cannot be established. Are you sure you want to connect? When I type yes and the password, it tells me permission is denied.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I've seen that happen in summer when a router got too hot. It stopped working, so I reset it, and then it worked for another two weeks before it died. If you have another router at hand, I'd definitely try that one.
     
  5. jopa123

    jopa123 New Member

    Falko,

    Thanks. Will do. This one may still be under warranty, as well. It's relatively new. Everything else on the router appears to be working just fine, tho. Including remote desktop and ftp to my Windows box, Tivo, and several other port forwarding operations.

    I also read something about RSA keys not being removed or reset after a reinstall of Ubuntu. Suggested fixes had something to do with removing the contents of the known_hosts file(s). This seems like to could explain the "degrading" of the system. Not sure how to test this theory, tho. I deleted the contents of the known_hosts file under root with no success. I don't know if there are other known_hosts under a different user. I don't mind deleting this file since I will probably rebuild the system anyway, once I isolate the problem. Any thoughts?

    Thanks again for the help.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    I don't think this is the problem because you had SSH problems even after a new install.
     
  7. jopa123

    jopa123 New Member

    Falko,

    I think that was the point of the thread, that RSA keys remained even after a fresh install.

    I have not been reformatting the disk between installs, I just follow the perfect server setup and assumed that all of the old stuff was being overwritten. Is that the case?

    Also, I have eliminated the router as a suspect. I put a new one in and forwarded port 22 to the internal IP address of the server.

    Same issues.

    Thanks.
     
  8. jopa123

    jopa123 New Member

    Perhaps one more clue. After the last few rebuilds, everything seems to boot fine to the base system but before I ever login once. I see the prompt with an odd message AFTER the prompt. It looks like this:

    server1 login: * Restarting OpenBSD Secure Shell server sshd

    Only after hitting enter to I get to the normal:

    server1 login:
     
  9. jopa123

    jopa123 New Member

    Eliminated another area

    I put a fresh hard drive in the machine and did a new install. Therefore, the RSA idea is definitely out.

    Maybe here is some more help.

    1) I can ping the machine.

    2) If I type "ssh localhost" or "ssh 192.168.1.x" it returns

    "[email protected] password:"

    When I enter the password from the install I get:

    "Permission denied. Please try again"
     
  10. jopa123

    jopa123 New Member

    Sorry for the multiple posts but I may be closing in on something.

    I find that if I set the static IP address in /etc/network/interfaces to just about anything other than the internal IP address that I have been using all along, I am able to ssh.

    Despite the fact that the ssh port 22 is not forwarded to this new IP address in the router.

    There are no other machines listed as using the old IP address in the DHCP table.

    Any ideas why this would be happening?
     

Share This Page